librelist archives

« back to archive

Wand now works on Python 3.2 and 3.3

Wand now works on Python 3.2 and 3.3

From:
Hong Minhee
Date:
2013-06-06 @ 18:31
Hi,

I am very happy to announce that Wand finally is compatible with Python 
3.2 or higher.  Although I said Wand 0.3 won’t work on Python 3 but it has
been shelved to Wand 0.4 before:

  https://minhee.quora.com/Wand-0-3-0a1-is-available

As prerequisite to Python 3 compatibility we had to switch over the test 
framework, so we’ve finally moved from Attest to pytest:

  https://github.com/dahlia/wand/issues/76#issuecomment-18990251

You can see the all-green status of Travis CI:

  https://travis-ci.org/dahlia/wand/builds/7849419

Note that the build matrix contains Python 3.2 and 3.3 as well.  :-)

This will be included in Wand 0.3 release.  It will be soon!  If you want 
to try using this right now, checkout python3 branch:

  $ git clone -b python3 git://github.com/dahlia/wand.git

Or simply download a tarball archive:

  https://github.com/dahlia/wand/archive/python3.tar.gz


Thanks,
Hong Minhee