librelist archives

« back to archive

shoes-3.2.19-gtk2-i686 or .20 loading user ruby lib

shoes-3.2.19-gtk2-i686 or .20 loading user ruby lib

From:
Douglas Allen
Date:
2015-02-11 @ 19:04
Hey all,

Those shoes install but wont run on Debian.
I noticed my lib is a copy of my user ruby not the system one.
Hacketyhack works fine. Is it using the system ruby? That ruby is 1.9
while my user one is 2.2
Could someone fix the installer script or tell me where to find the needed
changes.
Thanks.

Re: [shoes] shoes-3.2.19-gtk2-i686 or .20 loading user ruby lib

From:
Cecil Coupe
Date:
2015-02-11 @ 20:12
To fix it, I'll need a little more info about what you've done so far.
If you build Shoes 3.2 from source, it will use 'the installed' ruby 
which really should be rvm installed. Ruby 2.2. is not supported but 
might work in that setup.

If you download the 8MB Shoes 3.2.20 then it has its own copy of Ruby 
and won't use you system ruby or one in rvm.

Please file an issue at https://github.com/Shoes3/shoes3. If you want to 
fix it on your own, please read some of the wiki articles there that 
describe Shoes 3.2 in more detail.

--Cecil
On 02/11/2015 12:04 PM, Douglas Allen wrote:
> Hey all,
>
> Those shoes install but wont run on Debian.
> I noticed my lib is a copy of my user ruby not the system one.
> Hacketyhack works fine. Is it using the system ruby? That ruby is 1.9
> while my user one is 2.2
> Could someone fix the installer script or tell me where to find the 
> needed changes.
> Thanks.