librelist archives

« back to archive

error no such file to load

error no such file to load

From:
Olivier Morel
Date:
2014-02-20 @ 12:30
hy

i installed in shoes the gem net-ldap like that

Shoes.setup do
   gem 'net-ldap'
end

In my script ldap_connection.rb i have

require 'rubygems'
require 'net/ldap'


When i execute ldap_connection.rb i get the error  no such file to load
net/ldap

i dont understand why ? i try to find some solution in internet but i found
norhing :(

i use windows xp pr
-- 
Cordialement

Olivier Morel
tel : 06.62.25.03.77

Re: [shoes] error no such file to load

From:
Tobias Pfeiffer
Date:
2014-02-20 @ 13:08
Hi there,

difficult to say from here... just knowing that the shoes3 code should 
work e.g. like:

Shoes.setup do
   gem 'net-ldap'
end

require 'net-ldap'

in the same file. However, the shoes rubygems code is not exactly super 
cool so it might break at some points...

Cheers,
Tobi

On Thu 20 Feb 2014 01:30:53 PM CET, Olivier Morel wrote:
> hy
>
> i installed in shoes the gem net-ldap like that
>
> Shoes.setup do
>    gem 'net-ldap'
> end
>
> In my script ldap_connection.rb i have
>
> require 'rubygems'
> require 'net/ldap'
>
>
> When i execute ldap_connection.rb i get the error  no such file to load
> net/ldap
>
> i dont understand why ? i try to find some solution in internet but i found
> norhing :(
>
> i use windows xp pr

Re: [shoes] error no such file to load

From:
Tobias Pfeiffer
Date:
2014-02-20 @ 13:12
Hi there,

one more thing why it might not work:

"Net::LDAP requires a Ruby 1.9.3 compatible interpreter or better."

The downloadable shoes version is RUby 1.9.1 I believe... I compile my
own which works with 1.9.3 but yeah you'd have to compile your own. Sorry.

Tobi

On 02/20/2014 02:08 PM, Tobias Pfeiffer wrote:
> Hi there,
> 
> difficult to say from here... just knowing that the shoes3 code should 
> work e.g. like:
> 
> Shoes.setup do
>    gem 'net-ldap'
> end
> 
> require 'net-ldap'
> 
> in the same file. However, the shoes rubygems code is not exactly super 
> cool so it might break at some points...
> 
> Cheers,
> Tobi
> 
> On Thu 20 Feb 2014 01:30:53 PM CET, Olivier Morel wrote:
>> hy
>>
>> i installed in shoes the gem net-ldap like that
>>
>> Shoes.setup do
>>    gem 'net-ldap'
>> end
>>
>> In my script ldap_connection.rb i have
>>
>> require 'rubygems'
>> require 'net/ldap'
>>
>>
>> When i execute ldap_connection.rb i get the error  no such file to load
>> net/ldap
>>
>> i dont understand why ? i try to find some solution in internet but i found
>> norhing :(
>>
>> i use windows xp pr
> 

Re: [shoes] error no such file to load

From:
James Gifford
Date:
2014-02-20 @ 13:13
If it's the Linux version its 1.9.3 of some patch level from just over a
year ago.
On Feb 20, 2014 8:12 AM, "Tobias Pfeiffer" <
tobias.pfeiffer@student.hpi.uni-potsdam.de> wrote:

> Hi there,
>
> one more thing why it might not work:
>
> "Net::LDAP requires a Ruby 1.9.3 compatible interpreter or better."
>
> The downloadable shoes version is RUby 1.9.1 I believe... I compile my
> own which works with 1.9.3 but yeah you'd have to compile your own. Sorry.
>
> Tobi
>
> On 02/20/2014 02:08 PM, Tobias Pfeiffer wrote:
> > Hi there,
> >
> > difficult to say from here... just knowing that the shoes3 code should
> > work e.g. like:
> >
> > Shoes.setup do
> >    gem 'net-ldap'
> > end
> >
> > require 'net-ldap'
> >
> > in the same file. However, the shoes rubygems code is not exactly super
> > cool so it might break at some points...
> >
> > Cheers,
> > Tobi
> >
> > On Thu 20 Feb 2014 01:30:53 PM CET, Olivier Morel wrote:
> >> hy
> >>
> >> i installed in shoes the gem net-ldap like that
> >>
> >> Shoes.setup do
> >>    gem 'net-ldap'
> >> end
> >>
> >> In my script ldap_connection.rb i have
> >>
> >> require 'rubygems'
> >> require 'net/ldap'
> >>
> >>
> >> When i execute ldap_connection.rb i get the error  no such file to load
> >> net/ldap
> >>
> >> i dont understand why ? i try to find some solution in internet but i
> found
> >> norhing :(
> >>
> >> i use windows xp pr
> >
>
>

Re: [shoes] error no such file to load

From:
Tobias Pfeiffer
Date:
2014-02-20 @ 13:15
Well he uses Windows XP so sadly no afaik :-(

On Thu 20 Feb 2014 02:13:40 PM CET, James Gifford wrote:
> If it's the Linux version its 1.9.3 of some patch level from just over a
> year ago.
> On Feb 20, 2014 8:12 AM, "Tobias Pfeiffer" <
> tobias.pfeiffer@student.hpi.uni-potsdam.de> wrote:
>
>> Hi there,
>>
>> one more thing why it might not work:
>>
>> "Net::LDAP requires a Ruby 1.9.3 compatible interpreter or better."
>>
>> The downloadable shoes version is RUby 1.9.1 I believe... I compile my
>> own which works with 1.9.3 but yeah you'd have to compile your own. Sorry.
>>
>> Tobi
>>
>> On 02/20/2014 02:08 PM, Tobias Pfeiffer wrote:
>>> Hi there,
>>>
>>> difficult to say from here... just knowing that the shoes3 code should
>>> work e.g. like:
>>>
>>> Shoes.setup do
>>>    gem 'net-ldap'
>>> end
>>>
>>> require 'net-ldap'
>>>
>>> in the same file. However, the shoes rubygems code is not exactly super
>>> cool so it might break at some points...
>>>
>>> Cheers,
>>> Tobi
>>>
>>> On Thu 20 Feb 2014 01:30:53 PM CET, Olivier Morel wrote:
>>>> hy
>>>>
>>>> i installed in shoes the gem net-ldap like that
>>>>
>>>> Shoes.setup do
>>>>    gem 'net-ldap'
>>>> end
>>>>
>>>> In my script ldap_connection.rb i have
>>>>
>>>> require 'rubygems'
>>>> require 'net/ldap'
>>>>
>>>>
>>>> When i execute ldap_connection.rb i get the error  no such file to load
>>>> net/ldap
>>>>
>>>> i dont understand why ? i try to find some solution in internet but i
>> found
>>>> norhing :(
>>>>
>>>> i use windows xp pr
>>>
>>
>>
>

Re: [shoes] error no such file to load

From:
James Gifford
Date:
2014-02-20 @ 13:16
Hmmm.... I think it might be 1.9.2 based then. I'd have to check.

Either way, it probably won't work then.
On Feb 20, 2014 8:15 AM, "Tobias Pfeiffer" <
tobias.pfeiffer@student.hpi.uni-potsdam.de> wrote:

> Well he uses Windows XP so sadly no afaik :-(
>
> On Thu 20 Feb 2014 02:13:40 PM CET, James Gifford wrote:
> > If it's the Linux version its 1.9.3 of some patch level from just over a
> > year ago.
> > On Feb 20, 2014 8:12 AM, "Tobias Pfeiffer" <
> > tobias.pfeiffer@student.hpi.uni-potsdam.de> wrote:
> >
> >> Hi there,
> >>
> >> one more thing why it might not work:
> >>
> >> "Net::LDAP requires a Ruby 1.9.3 compatible interpreter or better."
> >>
> >> The downloadable shoes version is RUby 1.9.1 I believe... I compile my
> >> own which works with 1.9.3 but yeah you'd have to compile your own.
> Sorry.
> >>
> >> Tobi
> >>
> >> On 02/20/2014 02:08 PM, Tobias Pfeiffer wrote:
> >>> Hi there,
> >>>
> >>> difficult to say from here... just knowing that the shoes3 code should
> >>> work e.g. like:
> >>>
> >>> Shoes.setup do
> >>>    gem 'net-ldap'
> >>> end
> >>>
> >>> require 'net-ldap'
> >>>
> >>> in the same file. However, the shoes rubygems code is not exactly super
> >>> cool so it might break at some points...
> >>>
> >>> Cheers,
> >>> Tobi
> >>>
> >>> On Thu 20 Feb 2014 01:30:53 PM CET, Olivier Morel wrote:
> >>>> hy
> >>>>
> >>>> i installed in shoes the gem net-ldap like that
> >>>>
> >>>> Shoes.setup do
> >>>>    gem 'net-ldap'
> >>>> end
> >>>>
> >>>> In my script ldap_connection.rb i have
> >>>>
> >>>> require 'rubygems'
> >>>> require 'net/ldap'
> >>>>
> >>>>
> >>>> When i execute ldap_connection.rb i get the error  no such file to
> load
> >>>> net/ldap
> >>>>
> >>>> i dont understand why ? i try to find some solution in internet but i
> >> found
> >>>> norhing :(
> >>>>
> >>>> i use windows xp pr
> >>>
> >>
> >>
> >
>
>

Re: [shoes] error no such file to load

From:
Olivier Morel
Date:
2014-02-20 @ 15:44
so the problem is the version of ruby in shoes :(


2014-02-20 14:16 GMT+01:00 James Gifford <james@jamesrgifford.com>:

> Hmmm.... I think it might be 1.9.2 based then. I'd have to check.
>
> Either way, it probably won't work then.
> On Feb 20, 2014 8:15 AM, "Tobias Pfeiffer" <
> tobias.pfeiffer@student.hpi.uni-potsdam.de> wrote:
>
>> Well he uses Windows XP so sadly no afaik :-(
>>
>> On Thu 20 Feb 2014 02:13:40 PM CET, James Gifford wrote:
>> > If it's the Linux version its 1.9.3 of some patch level from just over a
>> > year ago.
>> > On Feb 20, 2014 8:12 AM, "Tobias Pfeiffer" <
>> > tobias.pfeiffer@student.hpi.uni-potsdam.de> wrote:
>> >
>> >> Hi there,
>> >>
>> >> one more thing why it might not work:
>> >>
>> >> "Net::LDAP requires a Ruby 1.9.3 compatible interpreter or better."
>> >>
>> >> The downloadable shoes version is RUby 1.9.1 I believe... I compile my
>> >> own which works with 1.9.3 but yeah you'd have to compile your own.
>> Sorry.
>> >>
>> >> Tobi
>> >>
>> >> On 02/20/2014 02:08 PM, Tobias Pfeiffer wrote:
>> >>> Hi there,
>> >>>
>> >>> difficult to say from here... just knowing that the shoes3 code should
>> >>> work e.g. like:
>> >>>
>> >>> Shoes.setup do
>> >>>    gem 'net-ldap'
>> >>> end
>> >>>
>> >>> require 'net-ldap'
>> >>>
>> >>> in the same file. However, the shoes rubygems code is not exactly
>> super
>> >>> cool so it might break at some points...
>> >>>
>> >>> Cheers,
>> >>> Tobi
>> >>>
>> >>> On Thu 20 Feb 2014 01:30:53 PM CET, Olivier Morel wrote:
>> >>>> hy
>> >>>>
>> >>>> i installed in shoes the gem net-ldap like that
>> >>>>
>> >>>> Shoes.setup do
>> >>>>    gem 'net-ldap'
>> >>>> end
>> >>>>
>> >>>> In my script ldap_connection.rb i have
>> >>>>
>> >>>> require 'rubygems'
>> >>>> require 'net/ldap'
>> >>>>
>> >>>>
>> >>>> When i execute ldap_connection.rb i get the error  no such file to
>> load
>> >>>> net/ldap
>> >>>>
>> >>>> i dont understand why ? i try to find some solution in internet but i
>> >> found
>> >>>> norhing :(
>> >>>>
>> >>>> i use windows xp pr
>> >>>
>> >>
>> >>
>> >
>>
>>


-- 
Cordialement

Olivier Morel
tel : 06.62.25.03.77

Re: [shoes] error no such file to load

From:
Tobias Pfeiffer
Date:
2014-02-20 @ 15:53
Most likely.. or the gem handling. Hard to tell at the moment and from 
here. Sorry!

On Thu 20 Feb 2014 04:44:46 PM CET, Olivier Morel wrote:
> so the problem is the version of ruby in shoes :(
>
>
> 2014-02-20 14:16 GMT+01:00 James Gifford <james@jamesrgifford.com>:
>
>> Hmmm.... I think it might be 1.9.2 based then. I'd have to check.
>>
>> Either way, it probably won't work then.
>> On Feb 20, 2014 8:15 AM, "Tobias Pfeiffer" <
>> tobias.pfeiffer@student.hpi.uni-potsdam.de> wrote:
>>
>>> Well he uses Windows XP so sadly no afaik :-(
>>>
>>> On Thu 20 Feb 2014 02:13:40 PM CET, James Gifford wrote:
>>>> If it's the Linux version its 1.9.3 of some patch level from just over a
>>>> year ago.
>>>> On Feb 20, 2014 8:12 AM, "Tobias Pfeiffer" <
>>>> tobias.pfeiffer@student.hpi.uni-potsdam.de> wrote:
>>>>
>>>>> Hi there,
>>>>>
>>>>> one more thing why it might not work:
>>>>>
>>>>> "Net::LDAP requires a Ruby 1.9.3 compatible interpreter or better."
>>>>>
>>>>> The downloadable shoes version is RUby 1.9.1 I believe... I compile my
>>>>> own which works with 1.9.3 but yeah you'd have to compile your own.
>>> Sorry.
>>>>>
>>>>> Tobi
>>>>>
>>>>> On 02/20/2014 02:08 PM, Tobias Pfeiffer wrote:
>>>>>> Hi there,
>>>>>>
>>>>>> difficult to say from here... just knowing that the shoes3 code should
>>>>>> work e.g. like:
>>>>>>
>>>>>> Shoes.setup do
>>>>>>    gem 'net-ldap'
>>>>>> end
>>>>>>
>>>>>> require 'net-ldap'
>>>>>>
>>>>>> in the same file. However, the shoes rubygems code is not exactly
>>> super
>>>>>> cool so it might break at some points...
>>>>>>
>>>>>> Cheers,
>>>>>> Tobi
>>>>>>
>>>>>> On Thu 20 Feb 2014 01:30:53 PM CET, Olivier Morel wrote:
>>>>>>> hy
>>>>>>>
>>>>>>> i installed in shoes the gem net-ldap like that
>>>>>>>
>>>>>>> Shoes.setup do
>>>>>>>    gem 'net-ldap'
>>>>>>> end
>>>>>>>
>>>>>>> In my script ldap_connection.rb i have
>>>>>>>
>>>>>>> require 'rubygems'
>>>>>>> require 'net/ldap'
>>>>>>>
>>>>>>>
>>>>>>> When i execute ldap_connection.rb i get the error  no such file to
>>> load
>>>>>>> net/ldap
>>>>>>>
>>>>>>> i dont understand why ? i try to find some solution in internet but i
>>>>> found
>>>>>>> norhing :(
>>>>>>>
>>>>>>> i use windows xp pr
>>>>>>
>>>>>
>>>>>
>>>>
>>>
>>>
>
>

Re: [shoes] error no such file to load

From:
Cecil Coupe
Date:
2014-02-20 @ 19:38
I've been digging in this section of Shoes for the last few weeks so 
this is timely.
For a work around,  try selecting a earlier specific version of the ldap 
gem that doesn't need
1.9.3 - use a version string with the "gem 'net-ldap' " line.

I believe ashbb did get Shoes3/Windows working with 1.9.2 but I don't 
remember if its the shipping
version.  Shoes with Ruby 1.9.3 has threading bugs on Windows and 
Shoes.setup, do gem xxx end
reliably causes a deadlock. The thread problem may be fixed by Ruby 
2.0.0. It may not.

If the gem needs to build C extensions, it just isn't going to work on 
Windows. That can fail in Linux too.

--Cecil
On 02/20/2014 08:53 AM, Tobias Pfeiffer wrote:
> Most likely.. or the gem handling. Hard to tell at the moment and from
> here. Sorry!
>
> On Thu 20 Feb 2014 04:44:46 PM CET, Olivier Morel wrote:
>> so the problem is the version of ruby in shoes :(
>>
>>
>> 2014-02-20 14:16 GMT+01:00 James Gifford <james@jamesrgifford.com>:
>>
>>> Hmmm.... I think it might be 1.9.2 based then. I'd have to check.
>>>
>>> Either way, it probably won't work then.
>>> On Feb 20, 2014 8:15 AM, "Tobias Pfeiffer" <
>>> tobias.pfeiffer@student.hpi.uni-potsdam.de> wrote:
>>>
>>>> Well he uses Windows XP so sadly no afaik :-(
>>>>
>>>> On Thu 20 Feb 2014 02:13:40 PM CET, James Gifford wrote:
>>>>> If it's the Linux version its 1.9.3 of some patch level from just over a
>>>>> year ago.
>>>>> On Feb 20, 2014 8:12 AM, "Tobias Pfeiffer" <
>>>>> tobias.pfeiffer@student.hpi.uni-potsdam.de> wrote:
>>>>>
>>>>>> Hi there,
>>>>>>
>>>>>> one more thing why it might not work:
>>>>>>
>>>>>> "Net::LDAP requires a Ruby 1.9.3 compatible interpreter or better."
>>>>>>
>>>>>> The downloadable shoes version is RUby 1.9.1 I believe... I compile my
>>>>>> own which works with 1.9.3 but yeah you'd have to compile your own.
>>>> Sorry.
>>>>>> Tobi
>>>>>>
>>>>>> On 02/20/2014 02:08 PM, Tobias Pfeiffer wrote:
>>>>>>> Hi there,
>>>>>>>
>>>>>>> difficult to say from here... just knowing that the shoes3 code should
>>>>>>> work e.g. like:
>>>>>>>
>>>>>>> Shoes.setup do
>>>>>>>     gem 'net-ldap'
>>>>>>> end
>>>>>>>
>>>>>>> require 'net-ldap'
>>>>>>>
>>>>>>> in the same file. However, the shoes rubygems code is not exactly
>>>> super
>>>>>>> cool so it might break at some points...
>>>>>>>
>>>>>>> Cheers,
>>>>>>> Tobi
>>>>>>>
>>>>>>> On Thu 20 Feb 2014 01:30:53 PM CET, Olivier Morel wrote:
>>>>>>>> hy
>>>>>>>>
>>>>>>>> i installed in shoes the gem net-ldap like that
>>>>>>>>
>>>>>>>> Shoes.setup do
>>>>>>>>     gem 'net-ldap'
>>>>>>>> end
>>>>>>>>
>>>>>>>> In my script ldap_connection.rb i have
>>>>>>>>
>>>>>>>> require 'rubygems'
>>>>>>>> require 'net/ldap'
>>>>>>>>
>>>>>>>>
>>>>>>>> When i execute ldap_connection.rb i get the error  no such file to
>>>> load
>>>>>>>> net/ldap
>>>>>>>>
>>>>>>>> i dont understand why ? i try to find some solution in internet but i
>>>>>> found
>>>>>>>> norhing :(
>>>>>>>>
>>>>>>>> i use windows xp pr
>>>>>>
>>>>
>>

Re: [shoes] error no such file to load

From:
Olivier Morel
Date:
2014-02-21 @ 10:39
Some one on irc told me to install shoes4 on windows
https://github.com/shoes/shoes4, for resolve the problem .
that's what i do but i dont understand why i cant execute a ruby script
gr...

the step

Start command Prompt with ruby  ( in bash of windows)

C:\Documents and Settings\zyriuse\shoes4\bin>../ext/install/shoes.bat
Error opening script file: C:/Documents (Le fichier spÚcifiÚ est
introuvable)



ps : that's really not possible to create an application for windows since
linux ? with shoes :)



2014-02-20 20:38 GMT+01:00 Cecil Coupe <ccoupe@cableone.net>:

> I've been digging in this section of Shoes for the last few weeks so
> this is timely.
> For a work around,  try selecting a earlier specific version of the ldap
> gem that doesn't need
> 1.9.3 - use a version string with the "gem 'net-ldap' " line.
>
> I believe ashbb did get Shoes3/Windows working with 1.9.2 but I don't
> remember if its the shipping
> version.  Shoes with Ruby 1.9.3 has threading bugs on Windows and
> Shoes.setup, do gem xxx end
> reliably causes a deadlock. The thread problem may be fixed by Ruby
> 2.0.0. It may not.
>
> If the gem needs to build C extensions, it just isn't going to work on
> Windows. That can fail in Linux too.
>
> --Cecil
> On 02/20/2014 08:53 AM, Tobias Pfeiffer wrote:
> > Most likely.. or the gem handling. Hard to tell at the moment and from
> > here. Sorry!
> >
> > On Thu 20 Feb 2014 04:44:46 PM CET, Olivier Morel wrote:
> >> so the problem is the version of ruby in shoes :(
> >>
> >>
> >> 2014-02-20 14:16 GMT+01:00 James Gifford <james@jamesrgifford.com>:
> >>
> >>> Hmmm.... I think it might be 1.9.2 based then. I'd have to check.
> >>>
> >>> Either way, it probably won't work then.
> >>> On Feb 20, 2014 8:15 AM, "Tobias Pfeiffer" <
> >>> tobias.pfeiffer@student.hpi.uni-potsdam.de> wrote:
> >>>
> >>>> Well he uses Windows XP so sadly no afaik :-(
> >>>>
> >>>> On Thu 20 Feb 2014 02:13:40 PM CET, James Gifford wrote:
> >>>>> If it's the Linux version its 1.9.3 of some patch level from just
> over a
> >>>>> year ago.
> >>>>> On Feb 20, 2014 8:12 AM, "Tobias Pfeiffer" <
> >>>>> tobias.pfeiffer@student.hpi.uni-potsdam.de> wrote:
> >>>>>
> >>>>>> Hi there,
> >>>>>>
> >>>>>> one more thing why it might not work:
> >>>>>>
> >>>>>> "Net::LDAP requires a Ruby 1.9.3 compatible interpreter or better."
> >>>>>>
> >>>>>> The downloadable shoes version is RUby 1.9.1 I believe... I compile
> my
> >>>>>> own which works with 1.9.3 but yeah you'd have to compile your own.
> >>>> Sorry.
> >>>>>> Tobi
> >>>>>>
> >>>>>> On 02/20/2014 02:08 PM, Tobias Pfeiffer wrote:
> >>>>>>> Hi there,
> >>>>>>>
> >>>>>>> difficult to say from here... just knowing that the shoes3 code
> should
> >>>>>>> work e.g. like:
> >>>>>>>
> >>>>>>> Shoes.setup do
> >>>>>>>     gem 'net-ldap'
> >>>>>>> end
> >>>>>>>
> >>>>>>> require 'net-ldap'
> >>>>>>>
> >>>>>>> in the same file. However, the shoes rubygems code is not exactly
> >>>> super
> >>>>>>> cool so it might break at some points...
> >>>>>>>
> >>>>>>> Cheers,
> >>>>>>> Tobi
> >>>>>>>
> >>>>>>> On Thu 20 Feb 2014 01:30:53 PM CET, Olivier Morel wrote:
> >>>>>>>> hy
> >>>>>>>>
> >>>>>>>> i installed in shoes the gem net-ldap like that
> >>>>>>>>
> >>>>>>>> Shoes.setup do
> >>>>>>>>     gem 'net-ldap'
> >>>>>>>> end
> >>>>>>>>
> >>>>>>>> In my script ldap_connection.rb i have
> >>>>>>>>
> >>>>>>>> require 'rubygems'
> >>>>>>>> require 'net/ldap'
> >>>>>>>>
> >>>>>>>>
> >>>>>>>> When i execute ldap_connection.rb i get the error  no such file to
> >>>> load
> >>>>>>>> net/ldap
> >>>>>>>>
> >>>>>>>> i dont understand why ? i try to find some solution in internet
> but i
> >>>>>> found
> >>>>>>>> norhing :(
> >>>>>>>>
> >>>>>>>> i use windows xp pr
> >>>>>>
> >>>>
> >>
>
>


-- 
Cordialement

Olivier Morel
tel : 06.62.25.03.77