librelist archives

« back to archive

Debian 7 and Shoes

Debian 7 and Shoes

From:
Ewan Slater
Date:
2014-01-22 @ 14:43
Hi,

I've just started with Ruby and Shoes.

I'm running on Debian 7, and I can't get Shoes to build.

Ruby version is 1.9.3

<exhibit a>

ewan@debian-7-xfce:~/shoes$ ruby --version
ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-linux]

</exhibit a>

I am attempting to build as per the instructions here:

https://github.com/shoes/shoes/wiki/Building-Shoes-on-Linux

When I run "bundle install" it all goes horribly wrong:

<exhibit b>

compiling xml_xpath_context.c
xml_xpath_context.c: In function ‘xpath_generic_exception_handler’:
xml_xpath_context.c:184:3: error: format not a string literal and no
format arguments [-Werror=format-security]
cc1: some warnings being treated as errors
make: *** [xml_xpath_context.o] Error 1


Gem files will remain installed in
/home/ewan/.bundler/tmp/3840/gems/nokogiri-1.5.0 for inspection.
Results logged to
/home/ewan/.bundler/tmp/3840/gems/nokogiri-1.5.0/ext/nokogiri/gem_make.out
An error occurred while installing nokogiri (1.5.0), and Bundler cannot
continue.
Make sure that `gem install nokogiri -v '1.5.0'` succeeds before bundling.

</exhibit b>

Any hints or suggestions gratefully received.

Cheers,

Ewan

Re: [shoes] Debian 7 and Shoes

From:
Tobias Pfeiffer
Date:
2014-01-22 @ 15:24
Hi,

do you have the libxml2-dev package installed?

(Linux Mint Debian Edition user here)

Cheers,
Tobi

On Wed 22 Jan 2014 03:43:36 PM CET, Ewan Slater wrote:
> Hi,
>
> I've just started with Ruby and Shoes.
>
> I'm running on Debian 7, and I can't get Shoes to build.
>
> Ruby version is 1.9.3
>
> <exhibit a>
>
> ewan@debian-7-xfce:~/shoes$ ruby --version
> ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-linux]
>
> </exhibit a>
>
> I am attempting to build as per the instructions here:
>
> https://github.com/shoes/shoes/wiki/Building-Shoes-on-Linux
>
> When I run "bundle install" it all goes horribly wrong:
>
> <exhibit b>
>
> compiling xml_xpath_context.c
> xml_xpath_context.c: In function ‘xpath_generic_exception_handler’:
> xml_xpath_context.c:184:3: error: format not a string literal and no
> format arguments [-Werror=format-security]
> cc1: some warnings being treated as errors
> make: *** [xml_xpath_context.o] Error 1
>
>
> Gem files will remain installed in
> /home/ewan/.bundler/tmp/3840/gems/nokogiri-1.5.0 for inspection.
> Results logged to
> /home/ewan/.bundler/tmp/3840/gems/nokogiri-1.5.0/ext/nokogiri/gem_make.out
> An error occurred while installing nokogiri (1.5.0), and Bundler cannot
> continue.
> Make sure that `gem install nokogiri -v '1.5.0'` succeeds before bundling.
>
> </exhibit b>
>
> Any hints or suggestions gratefully received.
>
> Cheers,
>
> Ewan