librelist archives

« back to archive

shoes4 and jruby issue

shoes4 and jruby issue

From:
Sebastjan Hribar
Date:
2013-01-16 @ 09:34
Hi,

I've followed the install instructions and also the recommendation for
the jruby version. I checked and I had 1.6 so I changed to 1.7 and now
every time I enter the shoes4 folder in the terminal I get this message:

 jruby-1.6.7.2 is not installed.
To install do: 'rvm install jruby-1.6.7.2'
Running /home/sebastjan/.rvm/hooks/after_cd


If I want to run a sample or my own test app, I get the message that
jruby is not found.

I am using Ubuntu 12.10 with rvm and ruby 1.9.


kind regards
seba

Re: [shoes] shoes4 and jruby issue

From:
Tobias Pfeiffer
Date:
2013-01-16 @ 10:35
Ji,

jruby 1.7 is right. We didn't specify that clearly enough in the .rvmrc 
we'll have to fix that :-) Sorry!

Cheers,
Tobi

On 16.01.2013 10:34, Sebastjan Hribar wrote:
> Hi,
>
> I've followed the install instructions and also the recommendation for
> the jruby version. I checked and I had 1.6 so I changed to 1.7 and now
> every time I enter the shoes4 folder in the terminal I get this message:
>
>   jruby-1.6.7.2 is not installed.
> To install do: 'rvm install jruby-1.6.7.2'
> Running /home/sebastjan/.rvm/hooks/after_cd
>
>
> If I want to run a sample or my own test app, I get the message that
> jruby is not found.
>
> I am using Ubuntu 12.10 with rvm and ruby 1.9.
>
>
> kind regards
> seba
>

Re: shoes4 and jruby issue

From:
Sebastjan Hribar
Date:
2013-01-16 @ 10:20
Dne 16.01.2013 (sre) ob 10:34 +0100 je Sebastjan Hribar napisal(a):
> Hi,
> 
> I've followed the install instructions and also the recommendation for
> the jruby version. I checked and I had 1.6 so I changed to 1.7 and now
> every time I enter the shoes4 folder in the terminal I get this message:
> 
>  jruby-1.6.7.2 is not installed.
> To install do: 'rvm install jruby-1.6.7.2'
> Running /home/sebastjan/.rvm/hooks/after_cd
> 
> 
> If I want to run a sample or my own test app, I get the message that
> jruby is not found.
> 
> I am using Ubuntu 12.10 with rvm and ruby 1.9.
> 
> 
> kind regards
> seba


I've installed jruby-1.6 again and now when I run a sample, it runs, but
this error message is still displayed:

Invalid gemspec in

[/home/sebastjan/.rvm/gems/jruby-1.6.7.2@shoes/specifications/nokogiri-1.5.6-java.gemspec]:
invalid byte sequence in UTF-8

regards
seba