librelist archives

« back to archive

[shoes4] Make sure you're using Jruby --1.9

[shoes4] Make sure you're using Jruby --1.9

From:
Peter Fitzgibbons
Date:
2012-05-29 @ 11:00
HI Folks,

I ran into an issue with rake/rspec that was special to Jruby --1.9
JRuby 1.9 mode throws load/error on
rspec/matchers/dsl<https://github.com/rspec/rspec-expectations/issues/147>Since
none of you have experienced this issue, I conclude that not all of
you are using Jruby --1.9 mode?
I guess this begs the answer... are we going to target 1.9 mode?
(caveat : Jruby will default to 1.9 mode in next release (1.7)

Thoughts?
Peter Fitzgibbons
(847) 859-9550
Email: peter.fitzgibbons@gmail.com
IM GTalk: peter.fitzgibbons
IM AOL: peter.fitzgibbons@gmail.com

Re: [shoes] [shoes4] Make sure you're using Jruby --1.9

From:
James Gifford
Date:
2012-05-29 @ 11:30
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Um, I'm just not experiencing it (I haven't pulled your changes to my
local box yet).

And jruby --1.9 is the default in the rakefile, bin/swt-shoooes and so
forth, so I'm a little confused... anyway, it's a good reminder.


James Gifford

On 05/29/2012 07:00 AM, Peter Fitzgibbons wrote:
> HI Folks,
> 
> I ran into an issue with rake/rspec that was special to Jruby
> --1.9
> 
> 
> JRuby 1.9 mode throws load/error on rspec/matchers/dsl 
> <https://github.com/rspec/rspec-expectations/issues/147>
> 
> Since none of you have experienced this issue, I conclude that not
> all of you are using Jruby --1.9 mode? I guess this begs the
> answer... are we going to target 1.9 mode? (caveat : Jruby will
> default to 1.9 mode in next release (1.7)
> 
> Thoughts? Peter Fitzgibbons (847) 859-9550 Email:
> peter.fitzgibbons@gmail.com <mailto:peter.fitzgibbons@gmail.com> IM
> GTalk: peter.fitzgibbons IM AOL: peter.fitzgibbons@gmail.com
> <mailto:peter.fitzgibbons@gmail.com>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQEcBAEBAgAGBQJPxLNTAAoJENbAQRq+BvX714YH/2jLsSMku1BA2Jg9xG3F4IU2
TpkrNDmvMxUXWx0BSwzHPv6ajOOnCPO8KveCYeUiQs/WjhYh1uCUoIX6nTL9XqHB
96W6Ow+wriYVcCKMRtWW7/MhEVDma+Pq/5tHiWlBp4uhBDPsGdgtsyJHMDzBJEn2
5bWDorJr3g+AdaXHtLawfsOxBh9bjPoqN1tqANckvI4g3qcGADLiv97Ymj0N0zu0
JZZMADFsfCwwafd9Yny4FgZ1+g5560uQHUTvFPNl4RFCznCyuKrYEfT1xlG002aH
02Ox6NSGtRD45tb7t7hz4i9FkAwakMx239SGAmxv/JUAAt9sG5yLqbZPKmvZO34=
=svZs
-----END PGP SIGNATURE-----

Re: [shoes] [shoes4] Make sure you're using Jruby --1.9

From:
Eric Watson
Date:
2012-05-29 @ 12:26
On May 29, 2012, at 6:30 AM, James Gifford wrote:

> And jruby --1.9 is the default in the rakefile, bin/swt-shoooes and so
> forth, so I'm a little confused... anyway, it's a good reminder.

I don't have my JRuby in 1.9 mode always, but this is true, when you run 
the rake spec:* tasks, it does add the --1.9 flag, so anyone running the 
rake tasks should be using 1.9 mode.

Is the problem only with a specific command?

Eric