librelist archives

« back to archive

Help us, text game

Help us, text game

From:
ashbb
Date:
2012-05-02 @ 23:48
Hi all,

I read this post in the ruby-talk ML:
http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-talk/395272

Jared said that the following text game didn't work.

https://gist.github.com/2558809

It works on my Windows 7 with Shoes 3 (0.r1514).
I don't know what platform he tried to run it on...

Could you confirm the text game on your environment?

ashbb

Re: [shoes] Help us, text game

From:
J. Kaiden
Date:
2012-05-03 @ 00:27
hi ashbb and Jared,

  i got the same error with Ubuntu 10.04 LTS - not sure if it's a platform
thing or not.

  does `require_relative` work with pre 1.9.2 ruby?

  i found that just a plain old `require` (not `require_relative) allows me
to run the script, but how do i play the game?!  i get a pale blue screen
with the title at the top and a progress bar at the bottom, what do i do
next?

  Shoes on...

 - j



On Wed, May 2, 2012 at 11:48 PM, ashbb <ashbbb@gmail.com> wrote:

> Hi all,
>
> I read this post in the ruby-talk ML:
> http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-talk/395272
>
> Jared said that the following text game didn't work.
>
> https://gist.github.com/2558809
>
> It works on my Windows 7 with Shoes 3 (0.r1514).
> I don't know what platform he tried to run it on...
>
> Could you confirm the text game on your environment?
>
> ashbb
>

Re: [shoes] Help us, text game

From:
ashbb
Date:
2012-05-03 @ 03:22
Hi J,

Thanks for trying on your Ubuntu!

> does `require_relative` work with pre 1.9.2 ruby?
Yes, I think so.
Because I'm using Shoes 3 (0.r1514) for Windows and it includes ruby 1.9.1.

> i found that just a plain old `require` (not `require_relative) allows me
to
> run the script,
Oh, good information! I'll tell him.

> but how do i play the game?!
Umm,...
After 3 seconds, the game will start automatically... No?
Watch a tiny demo:
http://www.rin-shun.com/shoes/text-game-on-red-shoes.swf.html

ashbb

Re: [shoes] Help us, text game

From:
David Eastman
Date:
2012-05-03 @ 01:03
as per previous thread, had this running in purple

On Thu, May 3, 2012 at 1:27 AM, J. Kaiden <jakekaiden@gmail.com> wrote:

> hi ashbb and Jared,
>
>   i got the same error with Ubuntu 10.04 LTS - not sure if it's a platform
> thing or not.
>
>   does `require_relative` work with pre 1.9.2 ruby?
>
>   i found that just a plain old `require` (not `require_relative) allows
> me to run the script, but how do i play the game?!  i get a pale blue
> screen with the title at the top and a progress bar at the bottom, what do
> i do next?
>
>   Shoes on...
>
>  - j
>
>
>
> On Wed, May 2, 2012 at 11:48 PM, ashbb <ashbbb@gmail.com> wrote:
>
>> Hi all,
>>
>> I read this post in the ruby-talk ML:
>> http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-talk/395272
>>
>> Jared said that the following text game didn't work.
>>
>> https://gist.github.com/2558809
>>
>> It works on my Windows 7 with Shoes 3 (0.r1514).
>> I don't know what platform he tried to run it on...
>>
>> Could you confirm the text game on your environment?
>>
>> ashbb
>>
>
>

Re: [shoes] Help us, text game

From:
ashbb
Date:
2012-05-03 @ 03:30
Hi David,

Yeah, at first, I've revised the text game code for Purple Shoes.
The code is here: https://gist.github.com/2516799

But this time, I mentioned another code: https://gist.github.com/2558809
That is for Red Shoes. ;-)

ashbb

Re: [shoes] Help us, text game

From:
Steve Klabnik
Date:
2012-05-03 @ 04:28
require_relative started in 1.9.1, yes.

Re: [shoes] Help us, text game

From:
Tobias Pfeiffer
Date:
2012-05-03 @ 09:15
On 05/03/2012 06:28 AM, Steve Klabnik wrote:
> require_relative started in 1.9.1, yes.
I found that require_relative sometimes works weird in a shoes 
environment (aka doesn't work as expected/throws errors)

Therfore in all my shoes projects I sadly use require './bla'