librelist archives

« back to archive

Purple Shoes Gem

Purple Shoes Gem

From:
ashbb
Date:
2012-03-24 @ 18:15
Hi all,

Uploaded Purple Shoes gem to RubyGems.org:
http://rubygems.org/gems/purple_shoes

And rewrote the install guide on README of github repo:
https://github.com/ashbb/purple_shoes

So, please confirm if the guide is correct on your platform and let me
know. :)

Cheers,
ashbb

Re: [shoes] Purple Shoes Gem

From:
Cecil Coupe
Date:
2012-03-25 @ 07:28
I had to 'rvm use jruby' before I did the 'gem install purple_shoes'

For some odd reason I had to do to do the gem install purple_shoes twice
before it showed up on the gem list --local. And it installed swt and
friends each time. Weird. 

But, I could got the -h results and I got the -m manual so it's mostly
working. I didn't get the manual front page you show in the README
(content area blank) but the left side menus appear to work.

In case you didn't know the page up/down click in the manuals scroll bar
doesn't work well and the manual is god awful slow compared to green and
red shoes. 

> ccoupe@twb:~$ java -version
> java version "1.6.0_22"
> OpenJDK Runtime Environment (IcedTea6 1.10.6) (6b22-1.10.6-0ubuntu1)
> OpenJDK 64-Bit Server VM (build 20.0-b11, mixed mode)

--Cecil

On Sun, 2012-03-25 at 03:15 +0900, ashbb wrote:
> Hi all,
> 
> Uploaded Purple Shoes gem to RubyGems.org:
> http://rubygems.org/gems/purple_shoes
> 
> And rewrote the install guide on README of github repo:
> https://github.com/ashbb/purple_shoes
> 
> So, please confirm if the guide is correct on your platform and let me
> know. :)
> 
> Cheers,
> ashbb

Re: [shoes] Purple Shoes Gem

From:
ashbb
Date:
2012-03-25 @ 09:06
Hi Cecil,

Wow, thank you for the quick review on Linux. :)

> For some odd reason I had to do the gem install purple_shoes twice
> before it showed up on the gem list --local.
Umm, weird..

> I didn't get the manual front page you show in the README
> (content area blank) but the left side menus appear to work.
Umm, also weird...

> In case you didn't know the page up/down click in the manuals scroll
> bar doesn't work well and the manual is god awful slow compared to
> green and red shoes.
Yeah, I think you are using arrow buttons at either end of scroll bar area.
I may have to adjust to incrementing the value.
If you grab and drag the thumb, you can jump to the point you want to go to
quickly. Although contents are not sliding. :-P

Anyway, I have to study more and find a better solution. ;-)

Regards,
ashbb

Re: [shoes] Purple Shoes Gem

From:
J. Kaiden
Date:
2012-03-26 @ 20:25
hi ashbb,

  well, trying to use purple shoes with ubuntu 10.04 lts and rvm.

  unfortunately i can only install up to jruby 1.6.5.1, and purple doesn't
seem to work...  i'll keep trying and get back to you when and if i get it
running - definitely an interesting project.

  - j

Re: [shoes] Purple Shoes Gem

From:
Peter Fitzgibbons
Date:
2012-03-26 @ 20:57
Anyone else building RedShoes  on OSX?

Are you using Ruby 1.9.3-p125 ?
Did you install deps w/ Homebrew?

I'm fishing for reasons this is failing.

Peter Fitzgibbons
(847) 859-9550
Email: peter.fitzgibbons@gmail.com
IM GTalk: peter.fitzgibbons
IM AOL: peter.fitzgibbons@gmail.com


On Mon, Mar 26, 2012 at 3:25 PM, J. Kaiden <jakekaiden@gmail.com> wrote:

> hi ashbb,
>
>   well, trying to use purple shoes with ubuntu 10.04 lts and rvm.
>
>   unfortunately i can only install up to jruby 1.6.5.1, and purple doesn't
> seem to work...  i'll keep trying and get back to you when and if i get it
> running - definitely an interesting project.
>
>   - j
>
>
>

Re: [shoes] Purple Shoes Gem

From:
Steve Klabnik
Date:
2012-03-26 @ 21:05
I've been building with 1.9.3 and using homebrew.

On Mon, Mar 26, 2012 at 4:57 PM, Peter Fitzgibbons
<peter.fitzgibbons@gmail.com> wrote:
> Anyone else building RedShoes  on OSX?
>
> Are you using Ruby 1.9.3-p125 ?
> Did you install deps w/ Homebrew?
>
> I'm fishing for reasons this is failing.
>
> Peter Fitzgibbons
> (847) 859-9550
> Email: peter.fitzgibbons@gmail.com
> IM GTalk: peter.fitzgibbons
> IM AOL: peter.fitzgibbons@gmail.com
>
>
>
> On Mon, Mar 26, 2012 at 3:25 PM, J. Kaiden <jakekaiden@gmail.com> wrote:
>>
>> hi ashbb,
>>
>>   well, trying to use purple shoes with ubuntu 10.04 lts and rvm.
>>
>>   unfortunately i can only install up to jruby 1.6.5.1, and purple doesn't
>> seem to work...  i'll keep trying and get back to you when and if i get it
>> running - definitely an interesting project.
>>
>>   - j
>>
>>
>

Re: [shoes] Purple Shoes Gem

From:
Steve Klabnik
Date:
2012-03-26 @ 21:06
... and when I build HEAD, I get our old friend "LSOpenURLsWithRole()
failed with error -10810 for the file
/Users/steve/src/shoes/Shoes.app."

Re: [shoes] Purple Shoes Gem

From:
Peter Fitzgibbons
Date:
2012-03-26 @ 21:07
So you're past the build and have contents in ./build.

Hrm...

Peter Fitzgibbons
(847) 859-9550
Email: peter.fitzgibbons@gmail.com
IM GTalk: peter.fitzgibbons
IM AOL: peter.fitzgibbons@gmail.com


On Mon, Mar 26, 2012 at 4:06 PM, Steve Klabnik <steve@steveklabnik.com>wrote:

> ... and when I build HEAD, I get our old friend "LSOpenURLsWithRole()
> failed with error -10810 for the file
> /Users/steve/src/shoes/Shoes.app."
>

Re: [shoes] Purple Shoes Gem

From:
Steve Klabnik
Date:
2012-03-26 @ 21:13
Wait wait. I'm talking Red Shoes here, that's what you said. But this
is a purple shoes thread...

On Mon, Mar 26, 2012 at 5:07 PM, Peter Fitzgibbons
<peter.fitzgibbons@gmail.com> wrote:
> So you're past the build and have contents in ./build.
>
> Hrm...
>
>
> Peter Fitzgibbons
> (847) 859-9550
> Email: peter.fitzgibbons@gmail.com
> IM GTalk: peter.fitzgibbons
> IM AOL: peter.fitzgibbons@gmail.com
>
>
> On Mon, Mar 26, 2012 at 4:06 PM, Steve Klabnik <steve@steveklabnik.com>
> wrote:
>>
>> ... and when I build HEAD, I get our old friend "LSOpenURLsWithRole()
>> failed with error -10810 for the file
>> /Users/steve/src/shoes/Shoes.app."
>
>

Re: [shoes] Purple Shoes Gem

From:
Peter Fitzgibbons
Date:
2012-03-26 @ 21:18
Oops.  Unintentional hijacking.
I did not yell "Bomb"!!!

Peter Fitzgibbons
(847) 859-9550
Email: peter.fitzgibbons@gmail.com
IM GTalk: peter.fitzgibbons
IM AOL: peter.fitzgibbons@gmail.com


On Mon, Mar 26, 2012 at 4:13 PM, Steve Klabnik <steve@steveklabnik.com>wrote:

> Wait wait. I'm talking Red Shoes here, that's what you said. But this
> is a purple shoes thread...
>
> On Mon, Mar 26, 2012 at 5:07 PM, Peter Fitzgibbons
> <peter.fitzgibbons@gmail.com> wrote:
> > So you're past the build and have contents in ./build.
> >
> > Hrm...
> >
> >
> > Peter Fitzgibbons
> > (847) 859-9550
> > Email: peter.fitzgibbons@gmail.com
> > IM GTalk: peter.fitzgibbons
> > IM AOL: peter.fitzgibbons@gmail.com
> >
> >
> > On Mon, Mar 26, 2012 at 4:06 PM, Steve Klabnik <steve@steveklabnik.com>
> > wrote:
> >>
> >> ... and when I build HEAD, I get our old friend "LSOpenURLsWithRole()
> >> failed with error -10810 for the file
> >> /Users/steve/src/shoes/Shoes.app."
> >
> >
>

Re: [shoes] Purple Shoes Gem

From:
J. Kaiden
Date:
2012-03-26 @ 23:17
hi ashbb -

  still fidding around and trying to get purple to run, but with no luck -

  it seems that jruby 1.6.5.1 is the latest version available through rvm,
maybe that's the problem.  here's the error i get when trying `pshoes
[anything]` -

$ pshoes -m

SyntaxError:
/.../.rvm/gems/jruby-1.6.5.1/gems/purple_shoes-0.0.101/lib/purple_shoes.rb:13:
syntax error, unexpected ':'

  BASIC_ATTRIBUTES_DEFAULT = {left: 0, top: 0, width: 0, height: 0, angle:
0, curve: 0}
                                  ^
  require at org/jruby/RubyKernel.java:1038
  require at
/.../.rvm/gems/jruby-1.6.5.1/gems/purple_shoes-0.0.101/lib/purple_shoes.rb:36
   (root) at
/.../.rvm/gems/jruby-1.6.5.1/gems/purple_shoes-0.0.101/bin/pshoes:2
     load at org/jruby/RubyKernel.java:1063
   (root) at /.../.rvm/gems/jruby-1.6.5.1/bin/pshoes:19


  any ideas?

  thanks,

  - j

Re: [shoes] Purple Shoes Gem

From:
Peter Fitzgibbons
Date:
2012-03-27 @ 02:10
it's not running in -1.9 mode
The constant BASIC_ATTRIBUTES_DEFAULT is being set to a hash using new 1.9
syntax.

Sadly I don't have time right now to dive in.

Peter Fitzgibbons
(847) 859-9550
Email: peter.fitzgibbons@gmail.com
IM GTalk: peter.fitzgibbons
IM AOL: peter.fitzgibbons@gmail.com


On Mon, Mar 26, 2012 at 6:17 PM, J. Kaiden <jakekaiden@gmail.com> wrote:

> hi ashbb -
>
>   still fidding around and trying to get purple to run, but with no luck -
>
>   it seems that jruby 1.6.5.1 is the latest version available through rvm,
> maybe that's the problem.  here's the error i get when trying `pshoes
> [anything]` -
>
> $ pshoes -m
>
> SyntaxError:
> /.../.rvm/gems/jruby-1.6.5.1/gems/purple_shoes-0.0.101/lib/purple_shoes.rb:13:
> syntax error, unexpected ':'
>
>   BASIC_ATTRIBUTES_DEFAULT = {left: 0, top: 0, width: 0, height: 0, angle:
> 0, curve: 0}
>                                   ^
>   require at org/jruby/RubyKernel.java:1038
>   require at
> /.../.rvm/gems/jruby-1.6.5.1/gems/purple_shoes-0.0.101/lib/purple_shoes.rb:36
>    (root) at
> /.../.rvm/gems/jruby-1.6.5.1/gems/purple_shoes-0.0.101/bin/pshoes:2
>      load at org/jruby/RubyKernel.java:1063
>    (root) at /.../.rvm/gems/jruby-1.6.5.1/bin/pshoes:19
>
>
>   any ideas?
>
>   thanks,
>
>   - j
>

Re: [shoes] Purple Shoes Gem

From:
Tobias Pfeiffer
Date:
2012-03-27 @ 08:43
Well you could set the environment variable JRUBY_OPTS to include --1.9 
that would make your jruby run in 1.9 mode by default. 

http://stackoverflow.com/questions/4755900/how-to-make-jruby-1-6-default-to-ruby-1-9

On 03/27/2012 04:10 AM, Peter Fitzgibbons wrote:
> it's not running in -1.9 mode
> The constant BASIC_ATTRIBUTES_DEFAULT is being set to a hash using new 
> 1.9 syntax.
>
> Sadly I don't have time right now to dive in.
>
> Peter Fitzgibbons
> (847) 859-9550
> Email: peter.fitzgibbons@gmail.com <mailto:peter.fitzgibbons@gmail.com>
> IM GTalk: peter.fitzgibbons
> IM AOL: peter.fitzgibbons@gmail.com <mailto:peter.fitzgibbons@gmail.com>
>
>
> On Mon, Mar 26, 2012 at 6:17 PM, J. Kaiden <jakekaiden@gmail.com 
> <mailto:jakekaiden@gmail.com>> wrote:
>
>     hi ashbb -
>
>       still fidding around and trying to get purple to run, but with
>     no luck -
>
>       it seems that jruby 1.6.5.1 is the latest version available
>     through rvm, maybe that's the problem.  here's the error i get
>     when trying `pshoes [anything]` -
>
>     $ pshoes -m
>
>     SyntaxError:
>     
/.../.rvm/gems/jruby-1.6.5.1/gems/purple_shoes-0.0.101/lib/purple_shoes.rb:13:
>     syntax error, unexpected ':'
>
>       BASIC_ATTRIBUTES_DEFAULT = {left: 0, top: 0, width: 0, height:
>     0, angle: 0, curve: 0}
>                                       ^
>       require at org/jruby/RubyKernel.java:1038
>       require at
>     
/.../.rvm/gems/jruby-1.6.5.1/gems/purple_shoes-0.0.101/lib/purple_shoes.rb:36
>        (root) at
>     /.../.rvm/gems/jruby-1.6.5.1/gems/purple_shoes-0.0.101/bin/pshoes:2
>          load at org/jruby/RubyKernel.java:1063
>        (root) at /.../.rvm/gems/jruby-1.6.5.1/bin/pshoes:19
>
>
>       any ideas?
>
>       thanks,
>
>       - j
>
>

Re: [shoes] Purple Shoes Gem

From:
Peter Fitzgibbons
Date:
2012-03-26 @ 21:06
Bah.
Can you successfully build latest 'develop' branch?

Peter Fitzgibbons
(847) 859-9550
Email: peter.fitzgibbons@gmail.com
IM GTalk: peter.fitzgibbons
IM AOL: peter.fitzgibbons@gmail.com


On Mon, Mar 26, 2012 at 4:05 PM, Steve Klabnik <steve@steveklabnik.com>wrote:

> I've been building with 1.9.3 and using homebrew.
>
> On Mon, Mar 26, 2012 at 4:57 PM, Peter Fitzgibbons
> <peter.fitzgibbons@gmail.com> wrote:
> > Anyone else building RedShoes  on OSX?
> >
> > Are you using Ruby 1.9.3-p125 ?
> > Did you install deps w/ Homebrew?
> >
> > I'm fishing for reasons this is failing.
> >
> > Peter Fitzgibbons
> > (847) 859-9550
> > Email: peter.fitzgibbons@gmail.com
> > IM GTalk: peter.fitzgibbons
> > IM AOL: peter.fitzgibbons@gmail.com
> >
> >
> >
> > On Mon, Mar 26, 2012 at 3:25 PM, J. Kaiden <jakekaiden@gmail.com> wrote:
> >>
> >> hi ashbb,
> >>
> >>   well, trying to use purple shoes with ubuntu 10.04 lts and rvm.
> >>
> >>   unfortunately i can only install up to jruby 1.6.5.1, and purple
> doesn't
> >> seem to work...  i'll keep trying and get back to you when and if i get
> it
> >> running - definitely an interesting project.
> >>
> >>   - j
> >>
> >>
> >
>