librelist archives

« back to archive

Fails on Mac 10.5 with require 'green_shoes'

Fails on Mac 10.5 with require 'green_shoes'

From:
ashbb
Date:
2011-12-23 @ 00:52
Hi all,

Look at https://github.com/ashbb/green_shoes/issues/58

Someone Mac user help us!

He said he was using Mac OS X 10.5.8 and ruby 1.9.3p0.

I've never used Mac, so I can't help him... :(

Regards,
ashbb

Re: [shoes] Fails on Mac 10.5 with require 'green_shoes'

From:
Wayne Brissette
Date:
2011-12-23 @ 13:28
ashbb:

I tried to install green shoes and it failed on my system this morning. 

Maybe somebody here can enlighten me a bit because I'm in the dark on this
one. Here are the lines from mkmf.log that seem to be related: 

"/usr/bin/gcc-4.2 
-I/Users/wayne/.rvm/rubies/ruby-1.9.3-p0/include/ruby-1.9.1/x86_64-darwin11.2.0
-I/Users/wayne/.rvm/rubies/ruby-1.9.3-p0/include/ruby-1.9.1/ruby/backward 
-I/Users/wayne/.rvm/rubies/ruby-1.9.3-p0/include/ruby-1.9.1 -I. 
-I/Users/wayne/.rvm/rubies/ruby-1.9.3-p0/lib/ruby/site_ruby/1.9.1/x86_64-darwin11.2.0

-I/Users/wayne/.rvm/rubies/ruby-1.9.3-p0/lib/ruby/vendor_ruby/1.9.1/x86_64-darwin11.2.0
-D_XOPEN_SOURCE -D_DARWIN_C_SOURCE    -O3 -ggdb -Wextra 
-Wno-unused-parameter -Wno-parentheses -Wno-long-long 
-Wno-missing-field-initializers -Wpointer-arith -Wwrite-strings 
-Wdeclaration-after-statement -Wshorten-64-to-32 
-Wimplicit-function-declaration  -fno-common -pipe -Wall   -c conftest.c"
conftest.c:4:18: error: node.h: No such file or directory
conftest.c:5: error: ‘NODE_ATTRASGN’ undeclared here (not in a function)
checked program was:
/* begin */
1: #include "ruby.h"
2: 
3: #include "ruby.h"
4: #include "node.h"
5: int node_attrasgn = (int)NODE_ATTRASGN;
/* end */

setup_win32: checking for Win32 OS... -------------------- no

--------------------

have_package: checking for atk... -------------------- no

-=-=-=-=-=-=-=-

The NODE_ATTRASGN line bothers me. 

Ideas? 

Wayne


On Dec 22, 2011, at 6:52 PM, ashbb wrote:

> Hi all,
> 
> Look at https://github.com/ashbb/green_shoes/issues/58
> 
> Someone Mac user help us!
> 
> He said he was using Mac OS X 10.5.8 and ruby 1.9.3p0.
> 
> I've never used Mac, so I can't help him... :(
> 
> Regards,
> ashbb

Re: [shoes] Fails on Mac 10.5 with require 'green_shoes'

From:
ashbb
Date:
2011-12-24 @ 00:28
Hi Wayne,

Thank you for trying to install Green Shoes on OS X.

I can't do any help on Mac. But I think it may be better to try to install
Ruby/GTK2 first.

ashbb