librelist archives

« back to archive

Mechanize/Nokogiri with Shoes

Mechanize/Nokogiri with Shoes

From:
scott
Date:
2010-03-25 @ 00:23
Has anyone run into a problem running mechanize in a Shoes app on 64bit 
ubuntu?
I keep getting the error:
../.shoes/+gem/gems/nokogiri-1.4.1/lib/nokogiri/nokogiri.so: wrong ELF 
class: ELFCLASS64 - 
../.shoes/+gem/gems/nokogiri-1.4.1/lib/nokogiri/nokogiri.so

I'm able to run the application from the command line just fine, outside 
of a shoes app.
Just wondering if anyone has seen this before, and might be able to 
point me in the right direction.  Thanks!

Re: [shoes] Mechanize/Nokogiri with Shoes

From:
Cecil Coupe
Date:
2010-03-25 @ 02:48
Perhaps your shoes is 32 bit? Did you build it from the source tar ball
or download a binary from somewhere?
Which version of Ubuntu? Which version of ruby?  

On Wed, 2010-03-24 at 20:23 -0400, scott wrote:
> Has anyone run into a problem running mechanize in a Shoes app on 64bit 
> ubuntu?
> I keep getting the error:
> ../.shoes/+gem/gems/nokogiri-1.4.1/lib/nokogiri/nokogiri.so: wrong ELF 
> class: ELFCLASS64 - 
> ../.shoes/+gem/gems/nokogiri-1.4.1/lib/nokogiri/nokogiri.so
> 
> I'm able to run the application from the command line just fine, outside 
> of a shoes app.
> Just wondering if anyone has seen this before, and might be able to 
> point me in the right direction.  Thanks!

Re: [shoes] Mechanize/Nokogiri with Shoes

From:
scott
Date:
2010-03-25 @ 10:39
I didn't see any options on the shoes download page for 64bit/32bit at 
shoes.heroku.com.  Is there a better place to go so that I can compile 
it myself - or even go with Policeman?

Using Ubuntu 9.10 and ruby 1.9.1

I was able to run a plain shoes app with just stacks/flows/paragraphs, 
but when I tried to add mechanize I got that error.

Cecil Coupe wrote:
> Perhaps your shoes is 32 bit? Did you build it from the source tar ball
> or download a binary from somewhere?
> Which version of Ubuntu? Which version of ruby?  
>
> On Wed, 2010-03-24 at 20:23 -0400, scott wrote:
>   
>> Has anyone run into a problem running mechanize in a Shoes app on 64bit 
>> ubuntu?
>> I keep getting the error:
>> ../.shoes/+gem/gems/nokogiri-1.4.1/lib/nokogiri/nokogiri.so: wrong ELF 
>> class: ELFCLASS64 - 
>> ../.shoes/+gem/gems/nokogiri-1.4.1/lib/nokogiri/nokogiri.so
>>
>> I'm able to run the application from the command line just fine, outside 
>> of a shoes app.
>> Just wondering if anyone has seen this before, and might be able to 
>> point me in the right direction.  Thanks!
>>     
>
>
>   

Re: [shoes] Mechanize/Nokogiri with Shoes

From:
i5m
Date:
2010-03-25 @ 11:01
Scott,

The shoes2.run will be 32-bit. If you want 64-bit you'll have to build
yourself. I'm afraid I can't help with linux, but lots of others on this
list can.

In the meantime, try the wiki entry (bottom of page for building on Ubuntu)

http://wiki.github.com/shoes/shoes/buildingshoes

<http://wiki.github.com/shoes/shoes/buildingshoes>and the comments from
zaius in this issue:

http://github.com/shoes/shoes/issues#issue/13

<http://github.com/shoes/shoes/issues#issue/13>
-----------------------
i5m.co.uk
GPG Key: 0xA18A602B


On Thu, Mar 25, 2010 at 10:39 AM, scott <stwerner@vt.edu> wrote:

> I didn't see any options on the shoes download page for 64bit/32bit at
> shoes.heroku.com.  Is there a better place to go so that I can compile
> it myself - or even go with Policeman?
>
> Using Ubuntu 9.10 and ruby 1.9.1
>
> I was able to run a plain shoes app with just stacks/flows/paragraphs,
> but when I tried to add mechanize I got that error.
>
> Cecil Coupe wrote:
> > Perhaps your shoes is 32 bit? Did you build it from the source tar ball
> > or download a binary from somewhere?
> > Which version of Ubuntu? Which version of ruby?
> >
> > On Wed, 2010-03-24 at 20:23 -0400, scott wrote:
> >
> >> Has anyone run into a problem running mechanize in a Shoes app on 64bit
> >> ubuntu?
> >> I keep getting the error:
> >> ../.shoes/+gem/gems/nokogiri-1.4.1/lib/nokogiri/nokogiri.so: wrong ELF
> >> class: ELFCLASS64 -
> >> ../.shoes/+gem/gems/nokogiri-1.4.1/lib/nokogiri/nokogiri.so
> >>
> >> I'm able to run the application from the command line just fine, outside
> >> of a shoes app.
> >> Just wondering if anyone has seen this before, and might be able to
> >> point me in the right direction.  Thanks!
> >>
> >
> >
> >
>
>

Re: [shoes] Mechanize/Nokogiri with Shoes

From:
Scott Werner
Date:
2010-03-25 @ 15:00
Thanks, ill check that out!

On Mar 25, 2010 7:01 AM, "i5m" <i5ivem@googlemail.com> wrote:

Scott,

The shoes2.run will be 32-bit. If you want 64-bit you'll have to build
yourself. I'm afraid I can't help with linux, but lots of others on this
list can.

In the meantime, try the wiki entry (bottom of page for building on Ubuntu)

http://wiki.github.com/shoes/shoes/buildingshoes

<http://wiki.github.com/shoes/shoes/buildingshoes>and the comments from
zaius in this issue:

http://github.com/shoes/shoes/issues#issue/13

<http://github.com/shoes/shoes/issues#issue/13>
-----------------------
i5m.co.uk
GPG Key: 0xA18A602B




On Thu, Mar 25, 2010 at 10:39 AM, scott <stwerner@vt.edu> wrote:
>
> I didn't see any options on ...