librelist archives

« back to archive

Building shoes on Ubuntu 9.10

Building shoes on Ubuntu 9.10

From:
Daniel Heath
Date:
2010-03-16 @ 10:21
Hi All,

I'm trying to compile shoes on Ubuntu 9.10.

So far, I can get it to produce files in the dist folder, but dist/shoes
segfaults instantly when run.

dist/shoes: line 22: 14244 Segmentation fault      LD_LIBRARY_PATH=$APPPATH
$APPPATH/shoes-bin "$@"

I'm running ruby 1.9.1

Any suggestions?

- Daniel

Re: [shoes] Building shoes on Ubuntu 9.10

From:
Csomay Mihaly
Date:
2010-03-16 @ 10:32
Daniel Heath <daniel.r.heath@gmail.com> writes:

> Hi All,
>
> I'm trying to compile shoes on Ubuntu 9.10.
>
> So far, I can get it to produce files in the dist folder, but dist/shoes
segfaults instantly when run.
>
> dist/shoes: line 22: 14244 Segmentation fault     
 LD_LIBRARY_PATH=$APPPATH $APPPATH/shoes-bin "$@"
>
> I'm running ruby 1.9.1
>
> Any suggestions?
>
> - Daniel

Just comment out/remove the 3 lines added by this commit:
http://github.com/shoes/shoes/commit/1fc71d0f4343f7adb740aed59b90ef93024ef5b6

csm

Re: [shoes] Building shoes on Ubuntu 9.10

From:
Daniel Heath
Date:
2010-03-16 @ 10:45
Thanks!

That sorted it right out.

On Tue, Mar 16, 2010 at 9:32 PM, Csomay Mihaly <list@csomay.hu> wrote:

> Daniel Heath <daniel.r.heath@gmail.com> writes:
>
> > Hi All,
> >
> > I'm trying to compile shoes on Ubuntu 9.10.
> >
> > So far, I can get it to produce files in the dist folder, but dist/shoes
> segfaults instantly when run.
> >
> > dist/shoes: line 22: 14244 Segmentation fault
>  LD_LIBRARY_PATH=$APPPATH $APPPATH/shoes-bin "$@"
> >
> > I'm running ruby 1.9.1
> >
> > Any suggestions?
> >
> > - Daniel
>
> Just comment out/remove the 3 lines added by this commit:
>
> http://github.com/shoes/shoes/commit/1fc71d0f4343f7adb740aed59b90ef93024ef5b6
>
> csm
>