librelist archives

« back to archive

Problems installing from

Problems installing from

From:
Martin Evans
Date:
2010-03-13 @ 22:10
Hi 
I'm trying to install shoes on mac os x snow leopard, but get errors when 
using the latest git repo.
Are there any instructions available on how to do this
regards
Martin

Re: [shoes] Problems installing from

From:
Steve Klabnik
Date:
2010-03-13 @ 22:52
Hey Martin-

There's actually quite a few issues with making Shoooes work on Show
Leopard. That's one of the things that's being worked on right now,
actually. You'll have some issues until they're fixed, hopefully in the next
few weeks.

The main issue is that Shoooes was using Carbon, and was generally not 64
bit ready, from what I understand.

-Steve

On Sat, Mar 13, 2010 at 5:10 PM, Martin Evans <martin@caggy.co.uk> wrote:

> Hi
> I'm trying to install shoes on mac os x snow leopard, but get errors when
> using the latest git repo.
> Are there any instructions available on how to do this
> regards
> Martin
>
>

Re: [shoes] Problems installing from

From:
Devyn Cairns
Date:
2010-03-14 @ 00:06
He's not on Snow Leopard, just Leopard (10.5)

On Sat, Mar 13, 2010 at 2:52 PM, Steve Klabnik <steve@steveklabnik.com>wrote:

> Hey Martin-
>
> There's actually quite a few issues with making Shoooes work on Show
> Leopard. That's one of the things that's being worked on right now,
> actually. You'll have some issues until they're fixed, hopefully in the next
> few weeks.
>
> The main issue is that Shoooes was using Carbon, and was generally not 64
> bit ready, from what I understand.
>
> -Steve
>
>
> On Sat, Mar 13, 2010 at 5:10 PM, Martin Evans <martin@caggy.co.uk> wrote:
>
>> Hi
>> I'm trying to install shoes on mac os x snow leopard, but get errors when
>> using the latest git repo.
>> Are there any instructions available on how to do this
>> regards
>> Martin
>>
>>
>


-- 
   ~devyn

Re: [shoes] Problems installing from

From:
Devyn Cairns
Date:
2010-03-14 @ 05:53
... never mind, got confused lol

On Sat, Mar 13, 2010 at 4:06 PM, Devyn Cairns <devyn.cairns@gmail.com>wrote:

> He's not on Snow Leopard, just Leopard (10.5)
>
>
> On Sat, Mar 13, 2010 at 2:52 PM, Steve Klabnik <steve@steveklabnik.com>wrote:
>
>> Hey Martin-
>>
>> There's actually quite a few issues with making Shoooes work on Show
>> Leopard. That's one of the things that's being worked on right now,
>> actually. You'll have some issues until they're fixed, hopefully in the next
>> few weeks.
>>
>> The main issue is that Shoooes was using Carbon, and was generally not 64
>> bit ready, from what I understand.
>>
>> -Steve
>>
>>
>> On Sat, Mar 13, 2010 at 5:10 PM, Martin Evans <martin@caggy.co.uk> wrote:
>>
>>> Hi
>>> I'm trying to install shoes on mac os x snow leopard, but get errors when
>>> using the latest git repo.
>>> Are there any instructions available on how to do this
>>> regards
>>> Martin
>>>
>>>
>>
>
>
> --
>    ~devyn
>



-- 
   ~devyn

Re: [shoes] Problems installing from

From:
Martin Evans
Date:
2010-03-14 @ 01:26
I'm on snow leopard really trying to get serial port to work

Sent from my iPhone

On 14 Mar 2010, at 00:06, Devyn Cairns <devyn.cairns@gmail.com> wrote:

> He's not on Snow Leopard, just Leopard (10.5)
>
> On Sat, Mar 13, 2010 at 2:52 PM, Steve Klabnik  
> <steve@steveklabnik.com> wrote:
> Hey Martin-
>
> There's actually quite a few issues with making Shoooes work on Show  
> Leopard. That's one of the things that's being worked on right now,  
> actually. You'll have some issues until they're fixed, hopefully in  
> the next few weeks.
>
> The main issue is that Shoooes was using Carbon, and was generally  
> not 64 bit ready, from what I understand.
>
> -Steve
>
>
> On Sat, Mar 13, 2010 at 5:10 PM, Martin Evans <martin@caggy.co.uk>  
> wrote:
> Hi
> I'm trying to install shoes on mac os x snow leopard, but get errors  
> when using the latest git repo.
> Are there any instructions available on how to do this
> regards
> Martin
>
>
>
>
>
> -- 
>    ~devyn

Re: [shoes] Problems installing from

From:
Cecil Coupe
Date:
2010-03-14 @ 01:54
gem's and Shoes has always been a bit confusing. The old site/mailing
list has a lot of hints. Shoes has it's own collection of gems so you
have to install the gem from within shoes. As I remember there are
several ways to do that (cmd line vs GUI). Theres also some commands at
the top if your shoes script you can add.   Which method are you using?

On Sun, 2010-03-14 at 01:26 +0000, Martin Evans wrote:
> I'm on snow leopard really trying to get serial port to work
> 
> Sent from my iPhone
> 
> On 14 Mar 2010, at 00:06, Devyn Cairns <devyn.cairns@gmail.com> wrote:
> 
> 
> 
> > He's not on Snow Leopard, just Leopard (10.5)
> > 
> > On Sat, Mar 13, 2010 at 2:52 PM, Steve Klabnik
> > <steve@steveklabnik.com> wrote:
> >         Hey Martin-
> >         
> >         
> >         There's actually quite a few issues with making Shoooes work
> >         on Show Leopard. That's one of the things that's being
> >         worked on right now, actually. You'll have some issues until
> >         they're fixed, hopefully in the next few weeks.
> >         
> >         
> >         The main issue is that Shoooes was using Carbon, and was
> >         generally not 64 bit ready, from what I understand.
> >         
> >         
> >         -Steve
> >         
> >         
> >         
> >         On Sat, Mar 13, 2010 at 5:10 PM, Martin Evans
> >         <martin@caggy.co.uk> wrote:
> >                 Hi
> >                 I'm trying to install shoes on mac os x snow
> >                 leopard, but get errors when using the latest git
> >                 repo.
> >                 Are there any instructions available on how to do
> >                 this
> >                 regards
> >                 Martin
> >                 
> >         
> >         
> > 
> > 
> > 
> > -- 
> >    ~devyn
> > 

Re: [shoes] Problems installing from

From:
Martin Evans
Date:
2010-03-14 @ 12:35
I've been installing from within the script, is it possible to still  
access the old mailing list or where can I find the old hints
Thanks
Martin

On 14 Mar 2010, at 01:54, Cecil Coupe <ccoupe@cableone.net> wrote:

> gem's and Shoes has always been a bit confusing. The old site/mailing
> list has a lot of hints. Shoes has it's own collection of gems so you
> have to install the gem from within shoes. As I remember there are
> several ways to do that (cmd line vs GUI). Theres also some commands  
> at
> the top if your shoes script you can add.   Which method are you  
> using?
>
> On Sun, 2010-03-14 at 01:26 +0000, Martin Evans wrote:
>> I'm on snow leopard really trying to get serial port to work
>>
>> Sent from my iPhone
>>
>> On 14 Mar 2010, at 00:06, Devyn Cairns <devyn.cairns@gmail.com>  
>> wrote:
>>
>>
>>
>>> He's not on Snow Leopard, just Leopard (10.5)
>>>
>>> On Sat, Mar 13, 2010 at 2:52 PM, Steve Klabnik
>>> <steve@steveklabnik.com> wrote:
>>>        Hey Martin-
>>>
>>>
>>>        There's actually quite a few issues with making Shoooes work
>>>        on Show Leopard. That's one of the things that's being
>>>        worked on right now, actually. You'll have some issues until
>>>        they're fixed, hopefully in the next few weeks.
>>>
>>>
>>>        The main issue is that Shoooes was using Carbon, and was
>>>        generally not 64 bit ready, from what I understand.
>>>
>>>
>>>        -Steve
>>>
>>>
>>>
>>>        On Sat, Mar 13, 2010 at 5:10 PM, Martin Evans
>>>        <martin@caggy.co.uk> wrote:
>>>                Hi
>>>                I'm trying to install shoes on mac os x snow
>>>                leopard, but get errors when using the latest git
>>>                repo.
>>>                Are there any instructions available on how to do
>>>                this
>>>                regards
>>>                Martin
>>>
>>>
>>>
>>>
>>>
>>>
>>> -- 
>>>   ~devyn
>>>
>
>

Re: [shoes] Problems installing from

From:
Steve Klabnik
Date:
2010-03-14 @ 16:06
You can read it here: http://groups.google.com/group/shoooes

Re: [shoes] Problems installing from

From:
Martin Evans
Date:
2010-03-13 @ 23:16
ok thanks, I've managed to get shoes 2 working bit am having problems 
getting setup gems to work, in particular I'm trying to
use a serialport gem but get an error during installation the console says
failed to load serialport.bundle. Any ideas how to 
get round this
thanks
Martin

On 13 Mar 2010, at 22:52, Steve Klabnik wrote:

> Hey Martin-
> 
> There's actually quite a few issues with making Shoooes work on Show 
Leopard. That's one of the things that's being worked on right now, 
actually. You'll have some issues until they're fixed, hopefully in the 
next few weeks.
> 
> The main issue is that Shoooes was using Carbon, and was generally not 
64 bit ready, from what I understand.
> 
> -Steve
> 
> On Sat, Mar 13, 2010 at 5:10 PM, Martin Evans <martin@caggy.co.uk> wrote:
> Hi
> I'm trying to install shoes on mac os x snow leopard, but get errors 
when using the latest git repo.
> Are there any instructions available on how to do this
> regards
> Martin
> 
>