librelist archives

« back to archive

Can't get shoes to package an app...

Can't get shoes to package an app...

From:
Simon Hicks
Date:
2009-12-01 @ 01:37
Hi all,

When I try to package something with shoes included, it tries to  
access "http://hacketyhack.net/pkg/#{platform}/shoes" which is of  
course no longer active. I've found the library that needs to be  
changed, but I can't find an alternative url to use... Has anyone  
found a way to package apps since hacketyhack.net went down?

ps. I'm sorry if this has been asked and answered a thousand times  
before, but I couldn't find any way of searching the mailing list  
archives to check first!

Re: Can't get shoes to package an app...

From:
Cecil Coupe
Date:
2009-12-01 @ 06:59
I've got a similar problem. I've got an old packaged script out in the
wild that wants to download shoes before it runs. I haven't bothered to
track it down to fix it, since they can download and install shoes from
the newer places and then run my script again. PITA for them.

The one thing I really liked about Shoes was the simple cross platform
packaging but it does depend on a single source which went "walk about"

On Tue, 2009-12-01 at 08:37 +0700, Simon Hicks wrote:
> Hi all,
> 
> When I try to package something with shoes included, it tries to  
> access "http://hacketyhack.net/pkg/#{platform}/shoes" which is of  
> course no longer active. I've found the library that needs to be  
> changed, but I can't find an alternative url to use... Has anyone  
> found a way to package apps since hacketyhack.net went down?
> 
> ps. I'm sorry if this has been asked and answered a thousand times  
> before, but I couldn't find any way of searching the mailing list  
> archives to check first!
> 
> 

Re: Can't get shoes to package an app...

From:
Vojta Salbaba
Date:
2009-12-01 @ 11:13
Unfortunately, hackety-hack is down since _why dissapearence.
The correct urls are
http://shoes.heroku.com/pkg/#{RELEASE_NAME.downcase}/#{platform}/shoes
and http://shoes.heroku.com
/pkg/#{RELEASE_NAME.downcase}/#{platform}/shoes-novideo
and it should stay like that for the time being.
Unfortunately, scripts packaged with _why era versions of shoes are not
fully supported. If you can, I suggest repackaging.
S pozdravem
 Vojtěch Šalbaba



2009/12/1 Cecil Coupe <ccoupe@cableone.net>

> I've got a similar problem. I've got an old packaged script out in the
> wild that wants to download shoes before it runs. I haven't bothered to
> track it down to fix it, since they can download and install shoes from
> the newer places and then run my script again. PITA for them.
>
> The one thing I really liked about Shoes was the simple cross platform
> packaging but it does depend on a single source which went "walk about"
>
> On Tue, 2009-12-01 at 08:37 +0700, Simon Hicks wrote:
> > Hi all,
> >
> > When I try to package something with shoes included, it tries to
> > access "http://hacketyhack.net/pkg/#{platform}/shoes" which is of
> > course no longer active. I've found the library that needs to be
> > changed, but I can't find an alternative url to use... Has anyone
> > found a way to package apps since hacketyhack.net went down?
> >
> > ps. I'm sorry if this has been asked and answered a thousand times
> > before, but I couldn't find any way of searching the mailing list
> > archives to check first!
> >
> >
>
>
>