librelist archives

« back to archive

will_paginate

will_paginate

From:
Esteban Fornal
Date:
2010-12-02 @ 14:36
buenas!,  tengo el sig error con el paginado

     undefined method `paginate'

creo para rails 3.0.3 necesito will_paginate 3.0.pre,
pero no la puedo instalar:

        bundle install

Fetching source index for http://rubygems.org/
Could not reach rubygems repository http://rubygems.org/
Could not find gem 'will_paginate (= 3.0.pre, runtime)' in any of the gem
sources listed in your Gemfil

        cat Gemfile
source 'http://rubygems.org'
source 'http://gemcutter.org'
gem 'rails', '3.0.3'
gem 'pg', '0.9.0'
gem "will_paginate", "3.0.pre"

        rvm use 1.9.1
Using /home/efornal/.rvm/gems/ruby-1.9.1-p378
        ruby -v
ruby 1.8.7 (2010-08-16 patchlevel 302) [i486-linux]

porque 1.8.7 ??
lo tengo instalado en el sistema, deberia usar solo rvm?
tiene q ver esto con el problema del paginado?

gracias!

Re: [rubysur] will_paginate

From:
Gaston Ramos
Date:
2010-12-03 @ 12:20
El Thu, 02 de Dec de 2010, a las 11:36:36AM -0300, Esteban Fornal dijo:
> buenas!,  tengo el sig error con el paginado
> 
>      undefined method `paginate'
> 
> creo para rails 3.0.3 necesito will_paginate 3.0.pre,
> pero no la puedo instalar:
> 
>         bundle install
> 
> Fetching source index for http://rubygems.org/
> Could not reach rubygems repository http://rubygems.org/
> Could not find gem 'will_paginate (= 3.0.pre, runtime)' in any of the gem
> sources listed in your Gemfil
Esteban, como la versión lo indica 3.0.pre es un pre release, no es un release,
entonces es probable que no exista más esa versión exacta de will_paginate, 
de hecho si te fijás en: http://www.railsplugins.org/plugins/92-will-paginate
ahora va por el pre2. entonces lo que te recomiendo es que pongas así:

gem 'will_paginate', '>= 3.0'

creo que con eso te debería funcionar.



> 
>         cat Gemfile
> source 'http://rubygems.org'
> source 'http://gemcutter.org'
> gem 'rails', '3.0.3'
> gem 'pg', '0.9.0'
> gem "will_paginate", "3.0.pre"
> 
>         rvm use 1.9.1
> Using /home/efornal/.rvm/gems/ruby-1.9.1-p378
>         ruby -v
> ruby 1.8.7 (2010-08-16 patchlevel 302) [i486-linux]
> 
> porque 1.8.7 ??
> lo tengo instalado en el sistema, deberia usar solo rvm?
> tiene q ver esto con el problema del paginado?
> 
> gracias!

-- 
"I always thought Smalltalk would beat Java, I just didn't know it would be
called 'Ruby' when it did."

   (Kent Beck)


+-------------------------------------+
Gastón Ramos
http://gastonramos.com.ar/
GNU/Linux Counter user #450312

Re: [rubysur] will_paginate

From:
Esteban Fornal
Date:
2010-12-03 @ 12:28
bien, porque ya lo habia restringido con gem 'will_paginate', '3.0.pre'
gracias!

2010/12/3 Gaston Ramos <ramos.gaston@gmail.com>

> El Thu, 02 de Dec de 2010, a las 11:36:36AM -0300, Esteban Fornal dijo:
> > buenas!,  tengo el sig error con el paginado
> >
> >      undefined method `paginate'
> >
> > creo para rails 3.0.3 necesito will_paginate 3.0.pre,
> > pero no la puedo instalar:
> >
> >         bundle install
> >
> > Fetching source index for http://rubygems.org/
> > Could not reach rubygems repository http://rubygems.org/
> > Could not find gem 'will_paginate (= 3.0.pre, runtime)' in any of the gem
> > sources listed in your Gemfil
> Esteban, como la versión lo indica 3.0.pre es un pre release, no es un
> release,
> entonces es probable que no exista más esa versión exacta de will_paginate,
> de hecho si te fijás en:
> http://www.railsplugins.org/plugins/92-will-paginate
> ahora va por el pre2. entonces lo que te recomiendo es que pongas así:
>
> gem 'will_paginate', '>= 3.0'
>
> creo que con eso te debería funcionar.
>
>
>
> >
> >         cat Gemfile
> > source 'http://rubygems.org'
> > source 'http://gemcutter.org'
> > gem 'rails', '3.0.3'
> > gem 'pg', '0.9.0'
> > gem "will_paginate", "3.0.pre"
> >
> >         rvm use 1.9.1
> > Using /home/efornal/.rvm/gems/ruby-1.9.1-p378
> >         ruby -v
> > ruby 1.8.7 (2010-08-16 patchlevel 302) [i486-linux]
> >
> > porque 1.8.7 ??
> > lo tengo instalado en el sistema, deberia usar solo rvm?
> > tiene q ver esto con el problema del paginado?
> >
> > gracias!
>
> --
> "I always thought Smalltalk would beat Java, I just didn't know it would be
> called 'Ruby' when it did."
>
>   (Kent Beck)
>
>
> +-------------------------------------+
> Gastón Ramos
> http://gastonramos.com.ar/
> GNU/Linux Counter user #450312
>

Re: [rubysur] will_paginate

From:
Juan Schwindt
Date:
2010-12-02 @ 14:50
Me parece que tenés un lío de versiones de ruby. Nosotros estamos usando
ruby 1.9.2 con Rails 3.0.3 y will_paginate 3.0.pre funciona bien. No creo
que a esta altura sea una buena idea usar 1.9.1.

Juan.

On Thu, Dec 2, 2010 at 11:36 AM, Esteban Fornal <efornal@gmail.com> wrote:

> buenas!,  tengo el sig error con el paginado
>
>      undefined method `paginate'
>
> creo para rails 3.0.3 necesito will_paginate 3.0.pre,
> pero no la puedo instalar:
>
>         bundle install
>
> Fetching source index for http://rubygems.org/
> Could not reach rubygems repository http://rubygems.org/
> Could not find gem 'will_paginate (= 3.0.pre, runtime)' in any of the gem
> sources listed in your Gemfil
>
>         cat Gemfile
> source 'http://rubygems.org'
> source 'http://gemcutter.org'
> gem 'rails', '3.0.3'
> gem 'pg', '0.9.0'
> gem "will_paginate", "3.0.pre"
>
>         rvm use 1.9.1
> Using /home/efornal/.rvm/gems/ruby-1.9.1-p378
>         ruby -v
> ruby 1.8.7 (2010-08-16 patchlevel 302) [i486-linux]
>
> porque 1.8.7 ??
> lo tengo instalado en el sistema, deberia usar solo rvm?
> tiene q ver esto con el problema del paginado?
>
> gracias!
>

Re: [rubysur] will_paginate

From:
Santiago Pastorino
Date:
2010-12-02 @ 15:46
Rails 3 no soporta Ruby 1.9.1

https://github.com/rails/rails/blob/master/railties/lib/rails/ruby_version_check.rb

Dicho sea de paso la implementación del checker está mal pero va a
pasar un buen tiempo antes que dé algún problema, de todas formas
sería bueno arreglarlo :).

Saludos.

2010/12/2 Juan Schwindt <juan@schwindt.org>:
> Me parece que tenés un lío de versiones de ruby. Nosotros estamos usando
> ruby 1.9.2 con Rails 3.0.3 y will_paginate 3.0.pre funciona bien. No creo
> que a esta altura sea una buena idea usar 1.9.1.
> Juan.
>
> On Thu, Dec 2, 2010 at 11:36 AM, Esteban Fornal <efornal@gmail.com> wrote:
>>
>> buenas!,  tengo el sig error con el paginado
>>
>>      undefined method `paginate'
>>
>> creo para rails 3.0.3 necesito will_paginate 3.0.pre,
>> pero no la puedo instalar:
>>
>>         bundle install
>>
>> Fetching source index for http://rubygems.org/
>> Could not reach rubygems repository http://rubygems.org/
>> Could not find gem 'will_paginate (= 3.0.pre, runtime)' in any of the gem
>> sources listed in your Gemfil
>>
>>         cat Gemfile
>> source 'http://rubygems.org'
>> source 'http://gemcutter.org'
>> gem 'rails', '3.0.3'
>> gem 'pg', '0.9.0'
>> gem "will_paginate", "3.0.pre"
>>
>>         rvm use 1.9.1
>> Using /home/efornal/.rvm/gems/ruby-1.9.1-p378
>>         ruby -v
>> ruby 1.8.7 (2010-08-16 patchlevel 302) [i486-linux]
>>
>> porque 1.8.7 ??
>> lo tengo instalado en el sistema, deberia usar solo rvm?
>> tiene q ver esto con el problema del paginado?
>>
>> gracias!
>
>

Re: [rubysur] will_paginate

From:
Esteban Fornal
Date:
2010-12-02 @ 16:22
pequeño detalle no? con ruby 1.9.2  instala la 3.0.pre.

2010/12/2 Santiago Pastorino <spastorino@gmail.com>

> Rails 3 no soporta Ruby 1.9.1
>
> 
https://github.com/rails/rails/blob/master/railties/lib/rails/ruby_version_check.rb
>
> Dicho sea de paso la implementación del checker está mal pero va a
> pasar un buen tiempo antes que dé algún problema, de todas formas
> sería bueno arreglarlo :).
>
> Saludos.
>
> 2010/12/2 Juan Schwindt <juan@schwindt.org>:
> > Me parece que tenés un lío de versiones de ruby. Nosotros estamos usando
> > ruby 1.9.2 con Rails 3.0.3 y will_paginate 3.0.pre funciona bien. No creo
> > que a esta altura sea una buena idea usar 1.9.1.
> > Juan.
> >
> > On Thu, Dec 2, 2010 at 11:36 AM, Esteban Fornal <efornal@gmail.com>
> wrote:
> >>
> >> buenas!,  tengo el sig error con el paginado
> >>
> >>      undefined method `paginate'
> >>
> >> creo para rails 3.0.3 necesito will_paginate 3.0.pre,
> >> pero no la puedo instalar:
> >>
> >>         bundle install
> >>
> >> Fetching source index for http://rubygems.org/
> >> Could not reach rubygems repository http://rubygems.org/
> >> Could not find gem 'will_paginate (= 3.0.pre, runtime)' in any of the
> gem
> >> sources listed in your Gemfil
> >>
> >>         cat Gemfile
> >> source 'http://rubygems.org'
> >> source 'http://gemcutter.org'
> >> gem 'rails', '3.0.3'
> >> gem 'pg', '0.9.0'
> >> gem "will_paginate", "3.0.pre"
> >>
> >>         rvm use 1.9.1
> >> Using /home/efornal/.rvm/gems/ruby-1.9.1-p378
> >>         ruby -v
> >> ruby 1.8.7 (2010-08-16 patchlevel 302) [i486-linux]
> >>
> >> porque 1.8.7 ??
> >> lo tengo instalado en el sistema, deberia usar solo rvm?
> >> tiene q ver esto con el problema del paginado?
> >>
> >> gracias!
> >
> >
>

Re: [rubysur] will_paginate

From:
Porta
Date:
2010-12-02 @ 14:47
On Thu, Dec 2, 2010 at 11:36 AM, Esteban Fornal <efornal@gmail.com> wrote:

> buenas!,  tengo el sig error con el paginado
>
>      undefined method `paginate'
>
> creo para rails 3.0.3 necesito will_paginate 3.0.pre,
> pero no la puedo instalar:
>
>         bundle install
>
> Fetching source index for http://rubygems.org/
> Could not reach rubygems repository http://rubygems.org/
> Could not find gem 'will_paginate (= 3.0.pre, runtime)' in any of the gem
> sources listed in your Gemfil
>
>         cat Gemfile
> source 'http://rubygems.org'
> source 'http://gemcutter.org'
> gem 'rails', '3.0.3'
> gem 'pg', '0.9.0'
> gem "will_paginate", "3.0.pre"
>
>         rvm use 1.9.1
> Using /home/efornal/.rvm/gems/ruby-1.9.1-p378
>         ruby -v
> ruby 1.8.7 (2010-08-16 patchlevel 302) [i486-linux]
>
> porque 1.8.7 ??
> lo tengo instalado en el sistema, deberia usar solo rvm?
> tiene q ver esto con el problema del paginado?
>
> gracias!
>


a mi esto me funcionó:

gem "will_paginate", "~> 3.0.pre2"

Porta.