librelist archives

« back to archive

Cannot configure p4est-1.1 or development

Cannot configure p4est-1.1 or development

From:
Bruno Turcksin
Date:
2014-12-08 @ 05:20
Hi everybody,

I cannot install p4est-1.1 or the development version of p4est. The problem
is during configure, I get :

error: cannot compile a simple Fortran program

I assume that the problem is due to the fact that I use clang 3.4.1 as
C/C++ compiler and gfortran 4.8.3 as fortran compiler. I use
--without-blas, so I don't need fortran. I can compile p4est-0.3.4.2
without any problem.

Best,

Bruno

Re: [p4est] Cannot configure p4est-1.1 or development

From:
Tobin Isaac
Date:
2014-12-08 @ 19:55
Hi Bruno,

Could you please send along your config.log file?

Thanks,
  Toby

On Sun, Dec 07, 2014 at 11:20:45PM -0600, Bruno Turcksin wrote:
> Hi everybody,
> 
> I cannot install p4est-1.1 or the development version of p4est. The problem
> is during configure, I get :
> 
> error: cannot compile a simple Fortran program
> 
> I assume that the problem is due to the fact that I use clang 3.4.1 as
> C/C++ compiler and gfortran 4.8.3 as fortran compiler. I use
> --without-blas, so I don't need fortran. I can compile p4est-0.3.4.2
> without any problem.
> 
> Best,
> 
> Bruno