librelist archives

« back to archive

VPS deploy: layout html but no content or css

VPS deploy: layout html but no content or css

From:
Stevan C Wing
Date:
2014-01-19 @ 18:38
Hi everyone,

I have moved my nest site (http://stevancw.com) off of heroku and on to a 
VPS. I have configured it with nginx and passenger and deployed with 
capistrano. It all seemed to work.

The page layout loads (html loads) but there is no content or css and the 
error page is rendered within the layout.
I have tried modifying the content variable in config.yml but no luck. 

Does anyone have any ideas. Does it have something to do with file paths?
I’m using haml as a template engine … perhaps that?


All the best,


Stevan

Re: [nesta] VPS deploy: layout html but no content or css

From:
Graham Ashton
Date:
2014-01-20 @ 09:52
On 19 Jan 2014, at 18:38, Stevan C Wing <stevancw@me.com> wrote:

> I have moved my nest site (http://stevancw.com) off of heroku and on to a VPS.

Is the site currently up? It isn’t loading for me.

> The page layout loads (html loads) but there is no content or css and 
the error page is rendered within the layout.
> I have tried modifying the content variable in config.yml but no luck. 

What shows up in the nginx/passenger error logs when you try and load a page?

> Does it have something to do with file paths?

It could be related to the content setting, but it might not be. I think 
we’ll need a bit more information about what your VPS is reporting in the 
logs, what everything’s set to, etc., in order to help you further.

We might need your nginx config too.

> I’m using haml as a template engine … perhaps that?

I can’t imagine how it would have any impact on it.

Cheers,
Graham