librelist archives

« back to archive

Re: [nesta] Install Error

Re: [nesta] Install Error

From:
Graham Ashton
Date:
2013-09-20 @ 23:04
What's your Ruby version? This looks suspiciously like the bug in Ruby's 
Yaml parser that caused so many issues a few versions ago.

Is recommend running on 1.9.3.

Greg Milby <gmilby@gmail.com> wrote:

>followed steps on the main site - got an error
>using ubuntu on vps
>the rest were just command line directions i followed.
>
>Tia!
>
>root@gmilby:/var/www/nesta/brainfart.u1st.us# nesta demo:content
>/usr/lib/ruby/1.9.1/psych.rb:203:in `parse': (<unknown>): did not find 
expected key while parsing a block mapping at line 4 column 1 
(Psych::SyntaxError)
>	from /usr/lib/ruby/1.9.1/psych.rb:203:in `parse_stream'
>	from /usr/lib/ruby/1.9.1/psych.rb:151:in `parse'
>	from /usr/lib/ruby/1.9.1/psych.rb:127:in `load'
>	from /var/lib/gems/1.9.1/gems/nesta-0.9.13/lib/nesta/config.rb:68:in `from_yaml'
>	from /var/lib/gems/1.9.1/gems/nesta-0.9.13/lib/nesta/config.rb:18:in 
`method_missing'
>	from /var/lib/gems/1.9.1/gems/nesta-0.9.13/lib/nesta/app.rb:23:in `<class:App>'
>	from /var/lib/gems/1.9.1/gems/nesta-0.9.13/lib/nesta/app.rb:18:in 
`<module:Nesta>'
>	from /var/lib/gems/1.9.1/gems/nesta-0.9.13/lib/nesta/app.rb:17:in `<top 
(required)>'
>	from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:55:in `require'
>	from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:55:in `require'
>	from /var/lib/gems/1.9.1/gems/nesta-0.9.13/lib/nesta/commands.rb:5:in 
`<top (required)>'
>	from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:55:in `require'
>	from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:55:in `require'
>	from /var/lib/gems/1.9.1/gems/nesta-0.9.13/bin/nesta:5:in `<top (required)>'
>	from /usr/local/bin/nesta:23:in `load'
>	from /usr/local/bin/nesta:23:in `<main>'