librelist archives

« back to archive

Issues with new articles.

Issues with new articles.

From:
Max McCarty
Date:
2013-09-13 @ 23:37
Greetings all,
I'm fairly new to Nesta.  Originally I set up my project on a Windows 
environment everything was working fine. However when I switched over to a
Linux Ubuntu 12.4 And ran into issues of new articles not displaying on 
the index page or under associated category.

I can navigate to the article localhost:9393/filename and it shows up 
fine. I have tried running under both shotgun and rackup with no 
difference.

But despite having a defined Date: 03 Sept 2013 it still won't show. On 
the actual page, the published is correctly showing the date, as well as 
the category. But neither on the home page/category page, will the 
article's title/summary Shows up.

 For clarification, the method to return the latest articles is still in 
place just as when you deploy a new site nothing with the index page has 
changed.
In addition I have played around with different dates to no avail and have
also tried the same test in the windows environment on the same project 
with success.

Any thoughts or suggestions would be greatly approach. 

Thanks again 
Max.

Re: [nesta] Issues with new articles.

From:
Graham Ashton
Date:
2013-09-14 @ 07:48
Interesting. I wonder if it's got something to do with windows and unix 
line endings. Seems unlikely though.

If you make a new article with a Linux editor, does it appear? If not, 
send me one of the files that doesn't show up and I'll see if I can work 
it out.

On 14 Sep 2013, at 00:37, Max McCarty <max.r.mccarty@gmail.com> wrote:

> Greetings all,
> I'm fairly new to Nesta.  Originally I set up my project on a Windows 
environment everything was working fine. However when I switched over to a
Linux Ubuntu 12.4 And ran into issues of new articles not displaying on 
the index page or under associated category.
> 
> I can navigate to the article localhost:9393/filename and it shows up 
fine. I have tried running under both shotgun and rackup with no 
difference.
> 
> But despite having a defined Date: 03 Sept 2013 it still won't show. On 
the actual page, the published is correctly showing the date, as well as 
the category. But neither on the home page/category page, will the 
article's title/summary Shows up.
> 
>  For clarification, the method to return the latest articles is still in
place just as when you deploy a new site nothing with the index page has 
changed.
> In add ition I have played around with different dates to no avail and 
have also tried the same test in the windows environment on the same 
project with success.
> 
> Any thoughts or suggestions would be greatly approach. 
> 
> Thanks again 
> Max.

Re: [nesta] Issues with new articles.

From:
Max McCarty
Date:
2013-09-14 @ 15:55
Graham
Oddly I found when I returned the system had applied updates prior to 
running into the issue (unknowingly).  So I did a reboot and that resolved
the issue (this morning).

I Appreciate you getting back and responding.



On Sep 14, 2013, at 3:48 AM, Graham Ashton <graham@effectif.com> wrote:

> Interesting. I wonder if it's got something to do with windows and unix 
line endings. Seems unlikely though.
> 
> If you make a new article with a Linux editor, does it appear? If not, 
send me one of the files that doesn't show up and I'll see if I can work 
it out.
> 
> On 14 Sep 2013, at 00:37, Max McCarty <max.r.mccarty@gmail.com> wrote:
> 
>> Greetings all,
>> I'm fairly new to Nesta.  Originally I set up my project on a Windows 
environment everything was working fine. However when I switched over to a
Linux Ubuntu 12.4 And ran into issues of new articles not displaying on 
the index page or under associated category.
>> 
>> I can navigate to the article localhost:9393/filename and it shows up 
fine. I have tried running under both shotgun and rackup with no 
difference.
>> 
>> But despite having a defined Date: 03 Sept 2013 it still won't show. On
the actual page, the published is correctly showing the date, as well as 
the category. But neither on the home page/category page, will the 
article's title/summary Shows up.
>> 
>>  For clarification, the method to return the latest articles is still 
in place just as when you deploy a new site nothing with the index page 
has changed.
>> In add ition I have played around with different dates to no avail and 
have also tried the same test in the windows environment on the same 
project with success.
>> 
>> Any thoughts or suggestions would be greatly approach. 
>> 
>> Thanks again 
>> Max.