librelist archives

« back to archive

Difficulties installing kramdown markdown processor

Difficulties installing kramdown markdown processor

From:
Jake Subs
Date:
2013-07-25 @ 16:24
I've tried installing the kramdown markdown processor,
http://kramdown.rubyforge.org, as I'd like to support some multimarkdown
features like definitiion lists.

I followed the instructions in the nesta docs:
http://nestacms.com/docs/creating-content/changing-the-markdown-processor

But I get this error message:
> LoadError at /
> cannot load such file -- kramdown
> file: template.rb location: require line: 144
> etc.

Any ideas? I'm _assuming_ I can leave the markdown as-is, but maybe I have
to alter some other settings?

tia, Jake


-- 
[~] Jake Rayson
[w] www.jrayson.co.uk
[e] subs@growdigital.org
[t] @growdigital

Re: [nesta] Difficulties installing kramdown markdown processor

From:
Graham Ashton
Date:
2013-07-25 @ 17:20
On 25 Jul 2013, at 17:24, Jake Subs <subs@growdigital.org> wrote:

> I've tried installing the kramdown markdown processor, [snip] but I get 
this error message:
> > LoadError at /
> > cannot load such file -- kramdown
> > file: template.rb location: require line: 144
> > etc.

Access to the failing code would make this easy to reproduce and 
investigate. Is that possible?

Re: [nesta] Difficulties installing kramdown markdown processor

From:
Graham Ashton
Date:
2013-07-25 @ 18:06
After adding kramdown to Gemfile and running bundle, did you restart your 
webserver?

If yes, give me access to the repo and I'll take a look.

Jake Subs <subs@growdigital.org> wrote:

>Ahh, snippets! 
>
>https://gist.github.com/growdigital/6081931
>
>thank you :)
>
>On 25 Jul 2013 18:21, "Graham Ashton" <graham@effectif.com> wrote:
>
>On 25 Jul 2013, at 17:24, Jake Subs <subs@growdigital.org> wrote:
>
>> I've tried installing the kramdown markdown processor, [snip] but I get
this error message:
>> > LoadError at /
>> > cannot load such file -- kramdown
>> > file: template.rb location: require line: 144
>> > etc.
>
>Access to the failing code would make this easy to reproduce and 
investigate. Is that possible?
>
>
>
>-- 
>[~] Jake Rayson
>[w] www.jrayson.co.uk
>[e] subs@growdigital.org
>[t] @growdigital
>

Difficulties installing kramdown markdown processor

From:
Jake Subs
Date:
2013-07-25 @ 17:28
Ahh, snippets!

https://gist.github.com/growdigital/6081931

thank you :)

On 25 Jul 2013 18:21, "Graham Ashton"
<graham@effectif.com<javascript:_e({}, 'cvml',
'graham@effectif.com');>>
wrote:

> On 25 Jul 2013, at 17:24, Jake Subs 
<subs@growdigital.org<javascript:_e({}, 'cvml', 'subs@growdigital.org');>>
> wrote:
>
> > I've tried installing the kramdown markdown processor, [snip] but I get
> this error message:
> > > LoadError at /
> > > cannot load such file -- kramdown
> > > file: template.rb location: require line: 144
> > > etc.
>
> Access to the failing code would make this easy to reproduce and
> investigate. Is that possible?
>


-- 
[~] Jake Rayson
[w] www.jrayson.co.uk
[e] subs@growdigital.org
[t] @growdigital