librelist archives

« back to archive

About using the latest gems?

About using the latest gems?

From:
Bobby Lee
Date:
2010-12-20 @ 22:48
Hi Graham,

Thanks so much for putting lots of efforts and love into Nesta.
The nesta gem sure seems to be a right move.
By the way, can we update the other gems to the latest version as well?

Before, I could just edit the Gemfile myself but now with nesta 0.9 gem...
all the other gems seems to be locked down?
Is there a way to manually override the other gems?

For instance, the default haml gem is haml (3.0.12).
However the latest haml gem is haml (3.0.25).
Before I could just edit/update the Gemfile myself and re-bundle but now I
get this message via bundler:

$ bundle show
You have requested:
  haml = 3.0.25

The bundle currently has haml locked at 3.0.12


$ bundle update haml
Bundler could not find compatible versions for gem "haml":
  In Gemfile:
    nesta (= 0.9.0) depends on
      haml (= 3.0.12)

    haml (3.0.25)


There are the gems which are behind on their versions...
builder (2.1.2) => (3.0.0)
haml (3.0.12) = >(3.0.25)

Can we get these updates... I find haml gets updates very frequently, any 
thoughts on being able to keep up with the latest version?


Cheers,
Bobby


 		 	   		  

Re: [nesta] About using the latest gems?

From:
Graham Ashton
Date:
2010-12-20 @ 23:57
On 20 Dec 2010, at 22:48, Bobby Lee wrote:

> By the way, can we update the other gems to the latest version as well?

Yes, things are getting a little out of date. I've got rubytracker.com 
monitoring it, but it wasn't working properly until very recently and I've
therefore not remembered to keep on top of it.

Here's a screenshot of Ruby Tracker's current thoughts on the situation:

http://cl.ly/3iIz

> Before, I could just edit the Gemfile myself but now with nesta 0.9 
gem... all the other gems seems to be locked down?
> Is there a way to manually override the other gems?

When you build a gem it's generally a good idea specify which versions 
it's been tested with. I've pinned them hard in the gemspec file, but I 
could specify the dependencies in a more lax manner (e.g. with >= instead 
of =).

In general I'm not a big fan of loose dependencies, but I think this 
situation warrants it. When embedding Nesta in Rails, for example, looser 
dependencies are probably a required. I've added an item to my todo list 
to get everything upgraded and look into it.

> Before I could just edit/update the Gemfile myself and re-bundle ...

If I slacken the dependencies you'd probably still be able to do that, but
I haven't tried it.

> Can we get these updates... I find haml gets updates very frequently, 
any thoughts on being able to keep up with the latest version?

Once I've fixed all the out of date gems, I think Ruby Tracker will email 
me when a dependency gets updated. Hopefully.

I'll try and get most of the versions bumped for 0.9.1.

I'm hoping rspec plays nicely with test-unit 2.x these days, and that I 
can actually upgrade both of them. Otherwise I might just have to shoot 
rspec.

Cheers,
Graham

P.S. How's that theme coming on?