librelist archives

« back to archive

IDLE Workings?

IDLE Workings?

From:
Aashish Patil
Date:
2013-09-19 @ 13:01
Hi -  

Wondering how startIdle: works in MailCore. 

I have this working and receive no errors but the startIdle never returns 
back when there is new data. It just times out. No errors too. 

Thanks, 

-- 
Aashish Patil
Sent with Sparrow (http://www.sparrowmailapp.com/?sig)

Re: [mailcore] IDLE Workings?

From:
Hoa V. Dinh
Date:
2013-09-19 @ 17:36
It's notified by server side. So if the server doesn't notify on new data,
MailCore won't notify. 
You usually need a poll (say every 15 minutes) in addition to IDLE.

-- 
Hoa V. Dinh


On Thursday, September 19, 2013 at 6:01 AM, Aashish Patil wrote:

> Hi -  
> 
> Wondering how startIdle: works in MailCore. 
> 
> I have this working and receive no errors but the startIdle never 
returns back when there is new data. It just times out. No errors too. 
> 
> Thanks, 
> 
> -- 
> Aashish Patil
> Sent with Sparrow (http://www.sparrowmailapp.com/?sig)
> 

Re: [mailcore] IDLE Workings?

From:
Aashish Patil
Date:
2013-09-20 @ 11:49
Thanks!

The poll is working fine but was hoping that IDLE would work. 

Aashish 

-- 
Aashish Patil
Sent with Sparrow (http://www.sparrowmailapp.com/?sig)


On Thursday, September 19, 2013 at 10:36 AM, Hoa V. Dinh wrote:

> It's notified by server side. So if the server doesn't notify on new 
data, MailCore won't notify. 
> You usually need a poll (say every 15 minutes) in addition to IDLE.
> 
> -- 
> Hoa V. Dinh
> 
> 
> On Thursday, September 19, 2013 at 6:01 AM, Aashish Patil wrote:
> 
> > Hi -  
> > 
> > Wondering how startIdle: works in MailCore. 
> > 
> > I have this working and receive no errors but the startIdle never 
returns back when there is new data. It just times out. No errors too. 
> > 
> > Thanks, 
> > 
> > -- 
> > Aashish Patil
> > Sent with Sparrow (http://www.sparrowmailapp.com/?sig)
> > 
> 

Re: [mailcore] IDLE Workings?

From:
Aashish Patil
Date:
2013-11-17 @ 02:39
Trying out IDLE on a yahoo account but keeps returning an error -

Initially ->
Domain=mailcore Code=9 "Protocol Error" UserInfo=0x1665f500
{NSLocalizedDescription=Protocol Error}

After repeatedly calling idle following error is returned
Domain=mailcore Code=5 "Parse error" UserInfo=0x1655d1f0
{NSLocalizedDescription=Parse error}

I think its probably because yahoo does not support IDLE - is that true?
Can't find any confirmed literature that yahoo imap does not support IDLE.

This is MailCore 1

Thanks,
Aashish



On Fri, Sep 20, 2013 at 4:49 AM, Aashish Patil <aashishpatil@gmail.com>wrote:

> Thanks!
>
> The poll is working fine but was hoping that IDLE would work.
>
> Aashish
>
> --
> Aashish Patil
> Sent with Sparrow <http://www.sparrowmailapp.com/?sig>
>
> On Thursday, September 19, 2013 at 10:36 AM, Hoa V. Dinh wrote:
>
>  It's notified by server side. So if the server doesn't notify on new
> data, MailCore won't notify.
> You usually need a poll (say every 15 minutes) in addition to IDLE.
>
> --
> Hoa V. Dinh
>
> On Thursday, September 19, 2013 at 6:01 AM, Aashish Patil wrote:
>
>  Hi -
>
> Wondering how startIdle: works in MailCore.
>
> I have this working and receive no errors but the startIdle never returns
> back when there is new data. It just times out. No errors too.
>
> Thanks,
>
> --
> Aashish Patil
> Sent with Sparrow <http://www.sparrowmailapp.com/?sig>
>
>
>
>

Re: [mailcore] IDLE Workings?

From:
Hoa V. Dinh
Date:
2013-11-17 @ 03:07
Capabilities will tell you that: 
Yahoo IMAP server doesn't implement IDLE.

-- 
Hoa V. Dinh


On Saturday, November 16, 2013 at 6:39 PM, Aashish Patil wrote:

> Trying out IDLE on a yahoo account but keeps returning an error - 
> 
> Initially -> 
> Domain=mailcore Code=9 "Protocol Error" UserInfo=0x1665f500 
{NSLocalizedDescription=Protocol Error}
> 
> After repeatedly calling idle following error is returned
> Domain=mailcore Code=5 "Parse error" UserInfo=0x1655d1f0 
{NSLocalizedDescription=Parse error}
> 
> I think its probably because yahoo does not support IDLE - is that true?
Can't find any confirmed literature that yahoo imap does not support IDLE.

> 
> This is MailCore 1 
> 
> Thanks,
> Aashish
> 
> 
> 
> On Fri, Sep 20, 2013 at 4:49 AM, Aashish Patil <aashishpatil@gmail.com 
(mailto:aashishpatil@gmail.com)> wrote:
> > Thanks!
> > 
> > The poll is working fine but was hoping that IDLE would work. 
> > 
> > Aashish
> > 
> > -- 
> > Aashish Patil
> > Sent with Sparrow (http://www.sparrowmailapp.com/?sig)
> > 
> > 
> > On Thursday, September 19, 2013 at 10:36 AM, Hoa V. Dinh wrote:
> > 
> > > It's notified by server side. So if the server doesn't notify on new
data, MailCore won't notify. 
> > > You usually need a poll (say every 15 minutes) in addition to IDLE.
> > > 
> > > -- 
> > > Hoa V. Dinh
> > > 
> > > 
> > > On Thursday, September 19, 2013 at 6:01 AM, Aashish Patil wrote:
> > > 
> > > > Hi -  
> > > > 
> > > > Wondering how startIdle: works in MailCore. 
> > > > 
> > > > I have this working and receive no errors but the startIdle never 
returns back when there is new data. It just times out. No errors too.  
> > > > 
> > > > Thanks, 
> > > > 
> > > > -- 
> > > > Aashish Patil
> > > > Sent with Sparrow (http://www.sparrowmailapp.com/?sig)
> > > > 
> > > 
> > 
> 

Re: [mailcore] IDLE Workings?

From:
Aashish Patil
Date:
2013-11-17 @ 08:49
<p> </p>

<p>Thanks Hoa.</p>

<p> </p>

<p>Aashish </p>

<p><br />
On 2013-11-17 03:07:21 +0000 <mailcore@librelist.com> 
wrote:</mailcore@librelist.com><br />
<br />
 </p>

<div id="reply-content">Capabilities will tell you that:</div>

<div id="reply-content">Yahoo IMAP server doesn't implement IDLE.</div>

<div id="1CCDEE8AE3664168B33B84C86A88C855">
<div> </div>
--<br />
Hoa V. Dinh
<div> </div>
</div>

<p style="color: #A0A0A8;">On Saturday, November 16, 2013 at 6:39 PM, 
Aashish Patil wrote:</p>

<blockquote 
style="border-left-style:solid;border-width:1px;margin-left:0px;padding-left:10px;"
type="cite">
<div id="quoted-message-content">
<div>
<div dir="ltr">Trying out IDLE on a yahoo account but keeps returning an 
error - 
<div> </div>

<div>Initially -> </div>

<div>Domain=mailcore Code=9 "Protocol Error" UserInfo=0x1665f500
{NSLocalizedDescription=Protocol Error}</div>

<div> </div>

<div>After repeatedly calling idle following error is returned</div>

<div>Domain=mailcore Code=5 "Parse error" UserInfo=0x1655d1f0 
{NSLocalizedDescription=Parse error}</div>

<div> </div>

<div>I think its probably because yahoo does not support IDLE - is that 
true? Can't find any confirmed literature that yahoo imap does not 
support IDLE. </div>

<div> </div>

<div>This is MailCore 1 </div>

<div> </div>

<div>Thanks,</div>

<div>Aashish</div>

<div> </div>
</div>

<div> 
<div>On Fri, Sep 20, 2013 at 4:49 AM, Aashish Patil <span dir="ltr"><<a
href="mailto:aashishpatil@gmail.com" 
target="_blank">aashishpatil@gmail.com</a>></span> wrote:

<blockquote type="cite">
<div>
<div style="font-family:Helvetica;font-size:13px">Thanks!
<div> </div>

<div>The poll is working fine but was hoping that IDLE would work. </div>

<div> </div>

<div><span><font color="#888888">Aashish</font></span></div>
</div>

<div>
<div>
<div> </div>

<div>-- </div>

<div>Aashish Patil</div>

<div>Sent with <a href="http://www.sparrowmailapp.com/?sig" 
target="_blank">Sparrow</a></div>

<div> </div>
</div>
</div>

<div>
<div>
<p style="color:#a0a0a8">On Thursday, September 19, 2013 at 10:36 AM, Hoa 
V. Dinh wrote:</p>

<blockquote type="cite">
<div>
<div>
<div>
<div><span>It's notified by server side. So if the server doesn't 
notify on new data, MailCore won't notify. </span></div>

<div><span>You usually need a poll (say every 15 minutes) in addition to 
IDLE.</span></div>

<div>
<div> </div>

<div><span>-- </span></div>

<div><span>Hoa V. Dinh</span></div>

<div> </div>
</div>

<p style="color:#a0a0a8"><span>On Thursday, September 19, 2013 at 6:01 AM,
Aashish Patil wrote:</span></p>

<blockquote type="cite">
<div>
<div>
<div>
<div><span><span>Hi -  </span></span></div>

<div> </div>

<div><span><span>Wondering how startIdle: works in 
MailCore. </span></span></div>

<div> </div>

<div><span><span>I have this working and receive no errors but the 
startIdle never returns back when there is new data. It just times out. No
errors too. </span></span></div>

<div> </div>

<div><span><span>Thanks,</span></span></div>

<div>
<div> </div>

<div><span><span>-- </span></span></div>

<div><span><span>Aashish Patil</span></span></div>

<div><span><span>Sent with <a href="http://www.sparrowmailapp.com/?sig" 
target="_blank">Sparrow</a></span></span></div>

<div> </div>
</div>
</div>
</div>
</div>
</blockquote>

<div> </div>
</div>
</div>
</div>
</blockquote>

<div> </div>
</div>
</div>
</div>
</blockquote>
</div>
</div>
</div>
</div>
</blockquote>

<div> </div>

<p> </p>

<p> </p>

<p> </p>

Re: [mailcore] IDLE Workings?

From:
Aashish Patil
Date:
2013-11-29 @ 16:03
Is there a way to cancel out of IDLE? For an iOS app, I'd like to stop IDLE
when app enters background. Disconnecting the folder or session seems to
cause a crash though and there is no cancel IDLE method.


On Sun, Nov 17, 2013 at 12:49 AM, Aashish Patil <aashishpatil@gmail.com>wrote:

>
>
> Thanks Hoa.
>
>
>
> Aashish
>
>
> On 2013-11-17 03:07:21 +0000  wrote:
>
>
> Capabilities will tell you that:
> Yahoo IMAP server doesn't implement IDLE.
>
> --
> Hoa V. Dinh
>
>
> On Saturday, November 16, 2013 at 6:39 PM, Aashish Patil wrote:
>
>  Trying out IDLE on a yahoo account but keeps returning an error -
>
> Initially ->
> Domain=mailcore Code=9 "Protocol Error" UserInfo=0x1665f500
> {NSLocalizedDescription=Protocol Error}
>
> After repeatedly calling idle following error is returned
> Domain=mailcore Code=5 "Parse error" UserInfo=0x1655d1f0
> {NSLocalizedDescription=Parse error}
>
> I think its probably because yahoo does not support IDLE - is that true?
> Can't find any confirmed literature that yahoo imap does not support IDLE.
>
> This is MailCore 1
>
> Thanks,
> Aashish
>
>
> On Fri, Sep 20, 2013 at 4:49 AM, Aashish Patil <aashishpatil@gmail.com>wrote:
>
>  Thanks!
>
> The poll is working fine but was hoping that IDLE would work.
>
> Aashish
>
> --
> Aashish Patil
> Sent with Sparrow <http://www.sparrowmailapp.com/?sig>
>
>
> On Thursday, September 19, 2013 at 10:36 AM, Hoa V. Dinh wrote:
>
>   It's notified by server side. So if the server doesn't notify on new
> data, MailCore won't notify.
> You usually need a poll (say every 15 minutes) in addition to IDLE.
>
> --
> Hoa V. Dinh
>
>
> On Thursday, September 19, 2013 at 6:01 AM, Aashish Patil wrote:
>
>   Hi -
>
> Wondering how startIdle: works in MailCore.
>
> I have this working and receive no errors but the startIdle never returns
> back when there is new data. It just times out. No errors too.
>
> Thanks,
>
> --
> Aashish Patil
> Sent with Sparrow <http://www.sparrowmailapp.com/?sig>
>
>
>
>
>
>
>
>
>
>
>
>
>
>