librelist archives

« back to archive

doesn't compile for iOS Device

doesn't compile for iOS Device

From:
Jan C.
Date:
2012-07-19 @ 14:26
Hi,
when I include the MailCore to my project in compiles/works fine on
the Simulator but if I build it for a device, the libcrypto cannot be
found:


ld: library not found for -lcrypto
clang: error: linker command failed with exit code 1 (use -v to see invocation)


Are there some special steps for follow to build for a device?

cheers

Re: [mailcore] doesn't compile for iOS Device

From:
Matt Ronge
Date:
2012-07-27 @ 01:45
Hey Jan, did you ever find out what was causing this?
--
Matt Ronge
mronge@mronge.com
iOS Developer & Consultant
Central Atomics Inc.




On Jul 19, 2012, at 9:26 AM, Jan C. wrote:

> Hi,
> when I include the MailCore to my project in compiles/works fine on
> the Simulator but if I build it for a device, the libcrypto cannot be
> found:
> 
> 
> ld: library not found for -lcrypto
> clang: error: linker command failed with exit code 1 (use -v to see invocation)
> 
> 
> Are there some special steps for follow to build for a device?
> 
> cheers

Re: [mailcore] doesn't compile for iOS Device

From:
Jan Chaloupecky
Date:
2012-07-27 @ 07:03
It looks like openssl is not compiling correctly. I'm getting those
warning (not errors)

Warning: no rule to process file
'$(PROJECT_DIR)/openssl/crypto/txt_db/txt_db.c' of type sourcecode.c.c
for architecture armv6


I removed arm6 from the target architectures in the openssl project
(ssl and crypto target) and now it compiles fine

http://cl.ly/IMOZ


Jan






On Fri, Jul 27, 2012 at 3:45 AM, Matt Ronge <mronge@mronge.com> wrote:
> Hey Jan, did you ever find out what was causing this?
> --
> Matt Ronge
> mronge@mronge.com
> iOS Developer & Consultant
> Central Atomics Inc.
>
>
>
>
> On Jul 19, 2012, at 9:26 AM, Jan C. wrote:
>
>> Hi,
>> when I include the MailCore to my project in compiles/works fine on
>> the Simulator but if I build it for a device, the libcrypto cannot be
>> found:
>>
>>
>> ld: library not found for -lcrypto
>> clang: error: linker command failed with exit code 1 (use -v to see invocation)
>>
>>
>> Are there some special steps for follow to build for a device?
>>
>> cheers
>



-- 
Jan

Re: [mailcore] doesn't compile for iOS Device

From:
Matt Ronge
Date:
2012-07-29 @ 20:41
The project has been updated and Armv6 has been removed so it should now
--
Matt Ronge
mronge@mronge.com
iOS Developer & Consultant
Central Atomics Inc.




On Jul 27, 2012, at 2:03 AM, Jan Chaloupecky wrote:

> It looks like openssl is not compiling correctly. I'm getting those
> warning (not errors)
> 
> Warning: no rule to process file
> '$(PROJECT_DIR)/openssl/crypto/txt_db/txt_db.c' of type sourcecode.c.c
> for architecture armv6
> 
> 
> I removed arm6 from the target architectures in the openssl project
> (ssl and crypto target) and now it compiles fine
> 
> http://cl.ly/IMOZ
> 
> 
> Jan
> 
> 
> 
> 
> 
> 
> On Fri, Jul 27, 2012 at 3:45 AM, Matt Ronge <mronge@mronge.com> wrote:
>> Hey Jan, did you ever find out what was causing this?
>> --
>> Matt Ronge
>> mronge@mronge.com
>> iOS Developer & Consultant
>> Central Atomics Inc.
>> 
>> 
>> 
>> 
>> On Jul 19, 2012, at 9:26 AM, Jan C. wrote:
>> 
>>> Hi,
>>> when I include the MailCore to my project in compiles/works fine on
>>> the Simulator but if I build it for a device, the libcrypto cannot be
>>> found:
>>> 
>>> 
>>> ld: library not found for -lcrypto
>>> clang: error: linker command failed with exit code 1 (use -v to see 
invocation)
>>> 
>>> 
>>> Are there some special steps for follow to build for a device?
>>> 
>>> cheers
>> 
> 
> 
> 
> -- 
> Jan

Re: [mailcore] doesn't compile for iOS Device

From:
Jan Chaloupecky
Date:
2012-07-27 @ 06:50
No not yet. Can you reproduce it? It looks like the libcrypto.a and
libssl.a are not copied to the DerivedData folder, hence the linker
error. Here is a screenshot. MailCore it self built successfully but
not the end user app.

http://cl.ly/IMDS




On Fri, Jul 27, 2012 at 3:45 AM, Matt Ronge <mronge@mronge.com> wrote:
> Hey Jan, did you ever find out what was causing this?
> --
> Matt Ronge
> mronge@mronge.com
> iOS Developer & Consultant
> Central Atomics Inc.
>
>
>
>
> On Jul 19, 2012, at 9:26 AM, Jan C. wrote:
>
>> Hi,
>> when I include the MailCore to my project in compiles/works fine on
>> the Simulator but if I build it for a device, the libcrypto cannot be
>> found:
>>
>>
>> ld: library not found for -lcrypto
>> clang: error: linker command failed with exit code 1 (use -v to see invocation)
>>
>>
>> Are there some special steps for follow to build for a device?
>>
>> cheers
>



-- 
Jan