librelist archives

« back to archive

pygit2, support for Python 2.5

pygit2, support for Python 2.5

From:
J. David Ibanez
Date:
2011-08-11 @ 20:35
Hello,

We are adding support for Python 3 to pygit2, see
https://github.com/libgit2/pygit2/issues/43

The problem is it is a pain to maintain Python 2.5 at the same time
(specially to write the unit tests, because of the byte/text string
changes introduced in Python 3).

I would like to drop support for Python 2.5 (then we would maintain
pygit2 for Python 2.6. 2.7, 3.1 and 3.2), would this bother someone?


Cheers,
-- 
J. David Ibáñez
Itaapy <http://www.itaapy.com>         Tel +33 (0)1 42 23 67 45
9 rue Darwin, 75018 Paris              Fax +33 (0)1 53 28 27 88