librelist archives

« back to archive

lein-deploy-uberjar question

lein-deploy-uberjar question

From:
Derek Brown
Date:
2013-10-28 @ 17:29
Has anyone used lein-deploy-uberjar? (https://clojars.org/lein-deploy-uberjar)

I'm looking to use it to deploy an uberjar to Nexus. I can use "lein 
deploy" to do it, but with that need to specify the group/artifact and 
path the the jar, and thought this might streamline things a bit.

With lein-deploy-uberjar I receive the following error:

Failed to deploy artifacts/metadata: No connector available to access 
repository inline (snapshots) of type default using the available 
factories FileRepositoryConnectorFactory, WagonRepositoryConnectorFactory

Thanks for any ideas,
Derek

Re: [leiningen] lein-deploy-uberjar question

From:
Charles Norton
Date:
2013-10-28 @ 19:24
unsubscribe

 
Charles M Norton
Database Programmer/Systems Integrator

Re: [leiningen] lein-deploy-uberjar question

From:
Ray Miller
Date:
2013-10-28 @ 19:41
Hi Derek,

On 28 October 2013 17:29, Derek Brown <DBrown@theladders.com> wrote:
> Has anyone used lein-deploy-uberjar?
> (https://clojars.org/lein-deploy-uberjar)
>
> I'm looking to use it to deploy an uberjar to Nexus. I can use "lein deploy"
> to do it, but with that need to specify the group/artifact and path the the
> jar, and thought this might streamline things a bit.

I haven't used that plugin, but I achieved something similar using
<https://github.com/pliant/lein-package>.

Ray.

Re: [leiningen] lein-deploy-uberjar question

From:
Ahmet Zeynel
Date:
2013-10-28 @ 22:27
unsubscribe


On Mon, Oct 28, 2013 at 1:29 PM, Derek Brown <DBrown@theladders.com> wrote:

>  Has anyone used lein-deploy-uberjar? (
> https://clojars.org/lein-deploy-uberjar)
>
>  I'm looking to use it to deploy an uberjar to Nexus. I can use "lein
> deploy" to do it, but with that need to specify the group/artifact and path
> the the jar, and thought this might streamline things a bit.
>
>  With lein-deploy-uberjar I receive the following error:
>
>  Failed to deploy artifacts/metadata: No connector available to access
> repository inline (snapshots) of type default using the available factories
> FileRepositoryConnectorFactory, WagonRepositoryConnectorFactory
>
>  Thanks for any ideas,
> Derek
>
>