librelist archives

« back to archive

version 2.7.3 crashes on sparc under ruby1.9

version 2.7.3 crashes on sparc under ruby1.9

From:
Hleb Valoshka
Date:
2012-08-09 @ 17:17
Hallo,

Eric, could you look at this build logs: [1], [2]. I have no idea what
goes wrong with sparc and, to tell the truth, I've never seen any
sparc machine (qemu-system-sparc doesn't work with current debian).

2.7.3 crashes with ruby 1.9.3.0 and 1.9.3.194 but 2.7.2 was ok with 1.9.3.0 [3].

[1] 
https://buildd.debian.org/status/fetch.php?pkg=ruby-kgio&arch=sparc&ver=2.7.3-1&stamp=1343565141

[2] 
https://buildd.debian.org/status/fetch.php?pkg=ruby-kgio&arch=sparc&ver=2.7.3-1&stamp=1331843923
1.9.3.0

[3] 
https://buildd.debian.org/status/fetch.php?pkg=ruby-kgio&arch=sparc&ver=2.7.2-1&stamp=1329783946

Re: [kgio] version 2.7.3 crashes on sparc under ruby1.9

From:
Eric Wong
Date:
2012-08-10 @ 20:10
Hleb Valoshka <375gnu@gmail.com> wrote:
> Hallo,
> 
> Eric, could you look at this build logs: [1], [2]. I have no idea what
> goes wrong with sparc and, to tell the truth, I've never seen any
> sparc machine (qemu-system-sparc doesn't work with current debian).
> 
> 2.7.3 crashes with ruby 1.9.3.0 and 1.9.3.194 but 2.7.2 was ok with 1.9.3.0 [3].

I doubt the changes from 2.7.2 -> 2.7.3 could've caused crashes, I
suspect something else in the stack (eglibc?) broke between them.

Does 2.7.4 work?

> [1] 
https://buildd.debian.org/status/fetch.php?pkg=ruby-kgio&arch=sparc&ver=2.7.3-1&stamp=1343565141
> 
> [2] 
https://buildd.debian.org/status/fetch.php?pkg=ruby-kgio&arch=sparc&ver=2.7.3-1&stamp=1331843923
> 1.9.3.0
> 
> [3] 
https://buildd.debian.org/status/fetch.php?pkg=ruby-kgio&arch=sparc&ver=2.7.2-1&stamp=1329783946

Hopefully the Debian SPARC maintainers can help narrow this down.  I
suspect other Ruby software has similar failures, too.  It's definitely
low priority for me (and probably you :)).

Somebody who cares about the platform should investigate.

If it makes your life easier, I wouldn't mind at all if you mark kgio as
unsupported on rare Debian platforms.  x86-64/x86 are my main
priorities.

Re: [kgio] version 2.7.3 crashes on sparc under ruby1.9

From:
Hleb Valoshka
Date:
2012-08-10 @ 20:32
On 8/10/12, Eric Wong <normalperson@yhbt.net> wrote:
> Does 2.7.4 work?

I don't know, I didn't package it.

> If it makes your life easier, I wouldn't mind at all if you mark kgio as
> unsupported on rare Debian platforms.  x86-64/x86 are my main
> priorities.

At least Wheeze will have 2.7.2 and we have enough time until the next
Debian release :)