librelist archives

« back to archive

[PATCH] tryopen: avoid ambiguous name for subst function

[PATCH] tryopen: avoid ambiguous name for subst function

From:
Eric Wong
Date:
2012-05-31 @ 22:25
Define rb_thread_blocking_region as a macro for MRI 1.8
to prevent confusing output in tools such as valgrind/gdb.
---

 I've pushed this to kgio master along with two of funny-falcon's
 patches:

 Sokolov Yura 'funny-falcon (2):
        Fix UnixClientReadServerWrite test class name
        use rb_str_subseq for tail string on write

 git://bogomips.org/kgio
 http://bogomips.org/kgio.git

 ext/kgio/tryopen.c | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/ext/kgio/tryopen.c b/ext/kgio/tryopen.c
index 6b63673..f8044a5 100644
--- a/ext/kgio/tryopen.c
+++ b/ext/kgio/tryopen.c
@@ -42,7 +42,7 @@ static VALUE nogvl_open(void *ptr)
 #  include "rubysig.h"
 typedef void rb_unblock_function_t(void *);
 typedef VALUE rb_blocking_function_t(void *);
-static VALUE rb_thread_blocking_region(
+static VALUE my_thread_blocking_region(
 	rb_blocking_function_t *fn, void *data1,
 	rb_unblock_function_t *ubf, void *data2)
 {
@@ -54,6 +54,8 @@ static VALUE rb_thread_blocking_region(
 
 	return rv;
 }
+#define rb_thread_blocking_region(fn,data1,ubf,data2) \
+        my_thread_blocking_region((fn),(data1),(ubf),(data2))
 #endif /* ! HAVE_RB_THREAD_BLOCKING_REGION */
 
 /*
-- 
Eric Wong