librelist archives

« back to archive

Missing the Rails 2.3.5 gem Please `gem install...

Missing the Rails 2.3.5 gem Please `gem install...

From:
Phil Thompson
Date:
2010-02-01 @ 16:28
When we try to run a build, we get the following error that Rails is not
installed. We've double and triple checked the running user, working dir etc
but can't find anything wrong. Rake runs normally when dropping to the
cmdline and running from the cloned repo.

> "Missing the Rails 2.3.5 gem. Please `gem install -v=2.3.5 rails`, update
your RAILS_GEM_VERSION setting in config/environment.rb for the Rails
version you do have installed, or comment out RAILS_GEM_VERSION to use the
latest version installed."


Any suggestions?


Thanks,
Phil
PureSolo Ltd

Re: [integrity] Missing the Rails 2.3.5 gem Please `gem install...

From:
Nick Quaranto
Date:
2010-02-01 @ 16:33
I bet this is bundler messing around with your PATH and RUBYOPT. Maybe apply
this patch and see if it helps:

http://gist.github.com/273075

Also, I wonder if the latest bundler (0.9.x) fixes this...

-Nick

On Mon, Feb 1, 2010 at 11:28 AM, Phil Thompson <phil@electricvisions.com>wrote:

> When we try to run a build, we get the following error that Rails is not
> installed. We've double and triple checked the running user, working dir etc
> but can't find anything wrong. Rake runs normally when dropping to the
> cmdline and running from the cloned repo.
>
> > "Missing the Rails 2.3.5 gem. Please `gem install -v=2.3.5 rails`, update
> your RAILS_GEM_VERSION setting in config/environment.rb for the Rails
> version you do have installed, or comment out RAILS_GEM_VERSION to use the
> latest version installed."
>
>
> Any suggestions?
>
>
> Thanks,
> Phil
> PureSolo Ltd
>
>
>

Re: [integrity] Missing the Rails 2.3.5 gem Please `gem install...

From:
Phil Thompson
Date:
2010-02-01 @ 17:02
That did indeed fix the problem. Thanks very much!

On 1 February 2010 16:33, Nick Quaranto <nick@quaran.to> wrote:

> I bet this is bundler messing around with your PATH and RUBYOPT. Maybe
> apply this patch and see if it helps:
>
> http://gist.github.com/273075
>
> Also, I wonder if the latest bundler (0.9.x) fixes this...
>
> -Nick
>
> On Mon, Feb 1, 2010 at 11:28 AM, Phil Thompson <phil@electricvisions.com>wrote:
>
>> When we try to run a build, we get the following error that Rails is not
>> installed. We've double and triple checked the running user, working dir etc
>> but can't find anything wrong. Rake runs normally when dropping to the
>> cmdline and running from the cloned repo.
>>
>> > "Missing the Rails 2.3.5 gem. Please `gem install -v=2.3.5 rails`,
>> update your RAILS_GEM_VERSION setting in config/environment.rb for the Rails
>> version you do have installed, or comment out RAILS_GEM_VERSION to use the
>> latest version installed."
>>
>>
>> Any suggestions?
>>
>>
>> Thanks,
>> Phil
>> PureSolo Ltd
>>
>>
>>
>