librelist archives

« back to archive

Integrity: do_sqlite gem

Integrity: do_sqlite gem

From:
Rafael Parra
Date:
2009-12-06 @ 03:03
Hi,

I am trying to install integrity but keep getting this error:

integrity migrate_db /home/ci/integrity/config.yml
/usr/local/lib/site_ruby/1.8/rubygems.rb:827:in `report_activate_error':
Could not find RubyGem do_sqlite3 (~> 0.9.11) (Gem::LoadError)
from /usr/local/lib/site_ruby/1.8/rubygems.rb:261:in `activate'
 from /usr/local/lib/site_ruby/1.8/rubygems.rb:68:in `gem'
from

/usr/lib/ruby/gems/1.8/gems/dm-core-0.9.11/lib/dm-core/adapters/sqlite3_adapter.rb:1
 from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
 from /usr/lib/ruby/gems/1.8/gems/dm-core-0.9.11/lib/dm-core.rb:146:in
`setup'
from

/usr/lib/ruby/gems/1.8/gems/integrity-0.1.11/bin/../lib/integrity/../integrity.rb:42:in
`new'
 from

/usr/lib/ruby/gems/1.8/gems/integrity-0.1.11/bin/../lib/integrity/installer.rb:31:in
`migrate_db'
from /usr/lib/ruby/gems/1.8/gems/thor-0.12.0/lib/thor/task.rb:37:in `send'
 from /usr/lib/ruby/gems/1.8/gems/thor-0.12.0/lib/thor/task.rb:37:in `run'
from /usr/lib/ruby/gems/1.8/gems/thor-0.12.0/lib/thor/invocation.rb:108:in
`invoke'
 from /usr/lib/ruby/gems/1.8/gems/thor-0.12.0/lib/thor/invocation.rb:115:in
`call'
from /usr/lib/ruby/gems/1.8/gems/thor-0.12.0/lib/thor/invocation.rb:115:in
`invoke'
 from /usr/lib/ruby/gems/1.8/gems/thor-0.12.0/lib/thor.rb:139:in `start'
from /usr/lib/ruby/gems/1.8/gems/thor-0.12.0/lib/thor/base.rb:351:in `start'
 from /usr/lib/ruby/gems/1.8/gems/thor-0.12.0/lib/thor.rb:126:in `start'
from /usr/lib/ruby/gems/1.8/gems/integrity-0.1.11/bin/integrity:4
 from /usr/bin/integrity:19:in `load'
from /usr/bin/integrity:19

I tried adding do_sqlite3 and removing it to no avail.

Any help is deeply appreciated.

Thanks



-- 
Rafael E. Parra
Mobile: (661) 378-6943
Email: eduardopa@gmail.com
http://www.rafaelparra.com

Re: Integrity: do_sqlite gem

From:
Simon Rozet
Date:
2009-12-06 @ 15:46
On Sun, Dec 6, 2009 at 4:03 AM, Rafael Parra <eduardopa@gmail.com> wrote:
>
> Hi,
> I am trying to install integrity but keep getting this error:
> integrity migrate_db /home/ci/integrity/config.yml

Looks like you're using a outdated version. Please see
http://integrityapp.com for install instructions.

-- 
Simon Rozet <simon@rozet.name> http://atonie.org