librelist archives

« back to archive

Addons Problem

Addons Problem

From:
Date:
2013-04-20 @ 11:25
<html><body><span style="font-family:Verdana; color:#000000; 
font-size:10pt;"><div>I have installed the latest version of  
Friendica (master) and all is well.</div><div>Per instructions I have 
uploaded addons-master to folder "addon".</div><div>When I click Plugins 
in Admin it is blank.</div><div>How do I correct 
this.<br></div><div><br></div><div>John 
Saleeby</div><div><br></div><div>Natchez, 
Mississippi</div></span></body></html>

Addons Problem

From:
Date:
2013-04-20 @ 11:29
I have installed the latest version of  Friendica (master) and all is
well.
Per instructions I have uploaded addons-master to folder "addon".
When I click Plugins in Admin it is blank.
How do I correct this.



John Saleeby


Natchez, Mississippi

Re: [friendica] Addons Problem

From:
Tobias Diekershoff
Date:
2013-04-21 @ 16:48
On Sat, 20 Apr 2013 04:29:07 -0700
<john@natchezms.us> wrote:

> I have installed the latest version of  Friendica (master) and all is
> well.
> Per instructions I have uploaded addons-master to folder "addon".
> When I click Plugins in Admin it is blank.
> How do I correct this.

I can confirm this. On a fresh install (VirtualBox with a php 5.3.3-7 on
Debian stable and friendica from git) after git clone the addon
repository into the /addon directory, the admin panel remains empty
when calling the /admin/plugins page (there is only the header and the
menu/nav stuff, but none of the addons are listed).

Adding them manually to the .htconfig.php file ($a->config
['system'['addon'] = 'buglink';) doesn't help. The addon is listed on
the admin panels overview page, but only there and neither
on /admin/plugins nor in the users settings in case the addon has
settings).

The admin panel on long running nodes (with current git code) works
fine with the administration of the addons.

Sorry that I cant help you more ATM John, but I've never looked at this
part of the ~friendica code before ;-)

so long
  Tobias

-- 
           \|/
           O O
/------uUu-/ \-uUu-----------------------------\
|          \_/   Tobias Diekershoff            |
| Web ........ www.diekershoff.net             |
|   @$HOME ... diekershoff.homeunix.net        |
| µ Blog ..... @$HOME/statusnet/bavatar        |
| Jabber ..... tobias@diekershoff.homeunix.net |
| ~friendica . tobias@diekershoff.homeunix.net |
| PGP-ID ..... 0x66A73B17                      |
\----------------------------------------------/

Re: [friendica] Addons Problem

From:
Date:
2013-04-21 @ 17:29
<html><body><span style="font-family:Verdana; color:#000000; 
font-size:10pt;"><div>Thanks for the reply;</div><div>After a few days of 
trying I finally solved my problem.<br></div><div><br></div><div>I had 
kept putting folder "addon" in th ROOT dir. When I moved it to the folder 
containing the  Friendica-Master files VIOLA - prob solved. 
<br></div><div><br></div><div>John 
Saleeby</div><div> </div><div>Natchez, 
Mississippi</div><div><br><br></div>
<blockquote id="replyBlockquote" webmail="1" style="border-left: 2px solid
blue; margin-left: 8px; padding-left: 8px; font-size:10pt; color:black; 
font-family:verdana;">
<div id="wmQuoteWrapper">
-------- Original Message --------<br>
Subject: Re: [friendica] Addons Problem<br>
From: Tobias Diekershoff <<a 
href="mailto:tobias@diekershoff.net">tobias@diekershoff.net</a>><br>
Date: Sun, April 21, 2013 11:48 am<br>
To: <a href="mailto:friendica@librelist.com">friendica@librelist.com</a><br>
<br>
On Sat, 20 Apr 2013 04:29:07 -0700<br>
<<a href="mailto:john@natchezms.us">john@natchezms.us</a>> wrote:<br>
<br>
> I have installed the latest version of  Friendica (master) and all is<br>
> well.<br>
> Per instructions I have uploaded addons-master to folder "addon".<br>
> When I click Plugins in Admin it is blank.<br>
> How do I correct this.<br>
<br>
I can confirm this. On a fresh install (VirtualBox with a php 5.3.3-7 on<br>
Debian stable and friendica from git) after git clone the addon<br>
repository into the /addon directory, the admin panel remains empty<br>
when calling the /admin/plugins page (there is only the header and the<br>
menu/nav stuff, but none of the addons are listed).<br>
<br>
Adding them manually to the .<a 
href="http://htconfig.php">htconfig.php</a> file ($a->config<br>
['system'['addon'] = 'buglink';) doesn't help. The addon is listed on<br>
the admin panels overview page, but only there and neither<br>
on /admin/plugins nor in the users settings in case the addon has<br>
settings).<br>
<br>
The admin panel on long running nodes (with current git code) works<br>
fine with the administration of the addons.<br>
<br>
Sorry that I cant help you more ATM John, but I've never looked at this<br>
part of the ~friendica code before ;-)<br>
<br>
so long<br>
  Tobias<br>
<br>
-- <br>
           \|/<br>
           O O<br>
/------uUu-/ \-uUu-----------------------------\<br>
|          \_/   Tobias Diekershoff            |<br>
| Web ........ <a 
href="http://www.diekershoff.net">www.diekershoff.net</a>             
|<br>
|   @$HOME ... <a 
href="http://diekershoff.homeunix.net">diekershoff.homeunix.net</a>
|<br>
| µ Blog ..... @$HOME/statusnet/bavatar        |<br>
| Jabber ..... <a 
href="mailto:tobias@diekershoff.homeunix.net">tobias@diekershoff.homeunix.net</a>
|<br>
| ~friendica . <a 
href="mailto:tobias@diekershoff.homeunix.net">tobias@diekershoff.homeunix.net</a>
|<br>
| PGP-ID ..... 0x66A73B17                      |<br>
\----------------------------------------------/<br>

</div>
</blockquote></span></body></html>

Re: [friendica] Addons Problem

From:
Tobias Diekershoff
Date:
2013-04-21 @ 17:48
On Sun, 21 Apr 2013 10:29:57 -0700
<john@natchezms.us> wrote:

> Thanks for the reply;
> After a few days of trying I finally solved my problem.
> I had kept putting folder "addon" in th ROOT dir. When I moved it to
> the folder containing the Friendica-Master files VIOLA - prob solved.

:-) great

and luckily I've made the same mistake m)

so long
  Tobias

-- 
           \|/
           O O
/------uUu-/ \-uUu-----------------------------\
|          \_/   Tobias Diekershoff            |
| Web ........ www.diekershoff.net             |
|   @$HOME ... diekershoff.homeunix.net        |
| µ Blog ..... @$HOME/statusnet/bavatar        |
| Jabber ..... tobias@diekershoff.homeunix.net |
| ~friendica . tobias@diekershoff.homeunix.net |
| PGP-ID ..... 0x66A73B17                      |
\----------------------------------------------/

Re: [friendica] Addons Problem

From:
Date:
2013-04-21 @ 17:53
<html><body><span style="font-family:Verdana; color:#000000; 
font-size:10pt;"><div>I am mystified as I  don't see my posting in 
the librelist (friendica) stream. How did you see 
it?<br></div><div><br></div><div>John 
Saleeby</div><div> </div><div>Natchez, 
Mississippi</div><div><br><br></div>
<blockquote id="replyBlockquote" webmail="1" style="border-left: 2px solid
blue; margin-left: 8px; padding-left: 8px; font-size:10pt; color:black; 
font-family:verdana;">
<div id="wmQuoteWrapper">
-------- Original Message --------<br>
Subject: Re: [friendica] Addons Problem<br>
From: Tobias Diekershoff <<a 
href="mailto:tobias@diekershoff.net">tobias@diekershoff.net</a>><br>
Date: Sun, April 21, 2013 12:48 pm<br>
To: <a href="mailto:friendica@librelist.com">friendica@librelist.com</a><br>
<br>
On Sun, 21 Apr 2013 10:29:57 -0700<br>
<<a href="mailto:john@natchezms.us">john@natchezms.us</a>> wrote:<br>
<br>
> Thanks for the reply;<br>
> After a few days of trying I finally solved my problem.<br>
> I had kept putting folder "addon" in th ROOT dir. When I moved it to<br>
> the folder containing the Friendica-Master files VIOLA - prob solved.<br>
<br>
:-) great<br>
<br>
and luckily I've made the same mistake m)<br>
<br>
so long<br>
  Tobias<br>
<br>
-- <br>
           \|/<br>
           O O<br>
/------uUu-/ \-uUu-----------------------------\<br>
|          \_/   Tobias Diekershoff            |<br>
| Web ........ <a 
href="http://www.diekershoff.net">www.diekershoff.net</a>             
|<br>
|   @$HOME ... <a 
href="http://diekershoff.homeunix.net">diekershoff.homeunix.net</a>
|<br>
| µ Blog ..... @$HOME/statusnet/bavatar        |<br>
| Jabber ..... <a 
href="mailto:tobias@diekershoff.homeunix.net">tobias@diekershoff.homeunix.net</a>
|<br>
| ~friendica . <a 
href="mailto:tobias@diekershoff.homeunix.net">tobias@diekershoff.homeunix.net</a>
|<br>
| PGP-ID ..... 0x66A73B17                      |<br>
\----------------------------------------------/<br>

</div>
</blockquote></span></body></html>

Re: [friendica] Addons Problem

From:
Tobias Diekershoff
Date:
2013-04-22 @ 20:22

john@natchezms.us schrieb:

>  I am mystified as I  don't see my posting
>  in the librelist (friendica) stream. How did you see
>  it?
I get it delivered by mail ;-)

so long
  Tobias
-- 
JID/~friendica: tobias@diekershoff.homeunix.net
www.diekershoff.net.     diekershoff.homeunix.net