librelist archives

« back to archive

problem installing friendica. please help.

problem installing friendica. please help.

From:
Joseph Capers
Date:
2013-11-02 @ 00:31
I am using a VPS with linux. I uploaded and extracted all files to the root
of my domain in cpanel. When I go to my site to install, it won't let me
get past the first page. How do I fix this?

I tried changing the htconfig.php file and even tried to import the
database. When I did that, friendica wouldn't let me log in, and wouldn't
send any emails, etc.

However, I create a new database and started everything from scratch. I
want to use the installer to make sure everything is correct. Please help.
Thank you.

This is the error message:

PHP cli binary(required)

PHP executable is not the php cli binary (could be cgi-fgci version)
Found PHP version: PHP 5.3.27 (cgi-fcgi) (built: Aug 2 2013 06:03:22)


You can see the problem at http://goodfoo.com

Re: [friendica] problem installing friendica. please help.

From:
Tony Baldwin
Date:
2013-11-02 @ 21:32
On Fri, Nov 01, 2013 at 08:31:25PM -0400, Joseph Capers wrote:

I think we're going to need more information.

> I am using a VPS with linux. I uploaded and extracted all files to the root
> of my domain in cpanel. When I go to my site to install, it won't let me
> get past the first page. How do I fix this?
> 
> I tried changing the htconfig.php file and even tried to import the
> database. When I did that, friendica wouldn't let me log in, and wouldn't
> send any emails, etc.

Do you have a mail server installed, like exim or sendmail?

> 
> However, I create a new database and started everything from scratch. I
> want to use the installer to make sure everything is correct. Please help.
> Thank you.
> 
> This is the error message:
> 
> PHP cli binary(required)
> 
> PHP executable is not the php cli binary (could be cgi-fgci version)
> Found PHP version: PHP 5.3.27 (cgi-fcgi) (built: Aug 2 2013 06:03:22)

Actually, that sounds like you do not have PHP installed.
What distro are you using?
Likely this can be remedied with aptitude or yum installation of PHP.

> 
> 
> You can see the problem at http://goodfoo.com

I just see a white/blank page, which generally means a PHP error.

./t
--
http://www.tonybaldwin.me

Re: [friendica] problem installing friendica. please help.

From:
tony baldwin
Date:
2013-11-04 @ 02:07
On Sat, November 2, 2013 4:32 pm, Tony Baldwin wrote:
> On Fri, Nov 01, 2013 at 08:31:25PM -0400, Joseph Capers wrote:
>
> I think we're going to need more information.
>
>> I am using a VPS with linux. I uploaded and extracted all files to the
>> root
>> of my domain in cpanel. When I go to my site to install, it won't let me
>> get past the first page. How do I fix this?
>>
>> I tried changing the htconfig.php file and even tried to import the
>> database. When I did that, friendica wouldn't let me log in, and
>> wouldn't
>> send any emails, etc.
>
> Do you have a mail server installed, like exim or sendmail?
>
>>
>> However, I create a new database and started everything from scratch. I
>> want to use the installer to make sure everything is correct. Please
>> help.
>> Thank you.
>>
>> This is the error message:
>>
>> PHP cli binary(required)
>>
>> PHP executable is not the php cli binary (could be cgi-fgci version)
>> Found PHP version: PHP 5.3.27 (cgi-fcgi) (built: Aug 2 2013 06:03:22)
>
> Actually, that sounds like you do not have PHP installed.

I should clarify, it seems you do not have php-cli installed.
If your package manager (yum, aptitude, whatever) can't find php-cli, try
php5-cli

./tony
-- 
http://www.tonybaldwin.info

Re: [friendica] problem installing friendica. please help.

From:
Mike Macgirvin
Date:
2013-11-04 @ 02:30
Tony you're coming in a bit late in the conversation. There is a php 
cli. It's just not the one found by the installer. So we need to add the 
path to the correct php cli binary in .htconfig.php. The problem here is 
that this is on page 1 of the installation and that file doesn't exist. 
If the file exists and isn't empty we skip the installation. So it's a 
chicken/egg problem.

Having an incorrect PHP path should be an advisory - we should not 
require any path settings to be made so that we can get to the next page 
of the install. We don't absolutely require that this is set correctly 
for installation. Once installation is complete, the file will exist and 
it can be edited and the correct path configured.

I know that in Red an incorrect PHP path is listed as optional and 
installation presumably continues. It seems that in Friendica it does 
not continue; making it impossible to install using anything but manual 
installation (which can be very tricky and which we would like to avoid).

Re: [friendica] problem installing friendica. please help.

From:
Tobias Diekershoff
Date:
2013-11-04 @ 07:58
On Mon, 04 Nov 2013 13:30:52 +1100
Mike Macgirvin <mike@macgirvin.com> wrote:

> Tony you're coming in a bit late in the conversation. There is a php 
> cli. 

Not according to what arrived here over the list ;-)

> I know that in Red an incorrect PHP path is listed as optional and 
> installation presumably continues. It seems that in Friendica it does 
> not continue; making it impossible to install using anything but
> manual installation (which can be very tricky and which we would like
> to avoid).

So we would need to backport the "optional" state of things back to
friendica and inform the user about this, so he can add the option to
the htconfig file after the installation is finished?

so long
  Tobias

-- 
           \|/
           O O
/------uUu-/ \-uUu-----------------------------\
|          \_/ i   Tobias Diekershoff          |
| Web ............ www.diekershoff.net         |
|   @$HOME ....... diekershoff.de              |
| Jabber ......... tobias@diekershoff.de       |
| ~friendica ..... tobias@f.diekershoff.de     |
| webbie / red# .. bavatar@diekershoff.de      |
| PGP-ID ......... 0xF17694A1                  |
\----------------------------------------------/