librelist archives

« back to archive

Webserver in Efene

Webserver in Efene

From:
Volker Mische
Date:
2011-12-15 @ 22:02
Hi,

I wanted to play with Efene as a webserver a bit. I found a tutorial
[1], but it doesn't work. I always get an empty reply back. Did the
syntax change?

I also didn't find anything other than the documentation about the REST
module [2], which isn't that useful :)

[1] http://marianoguerra.com.ar/efene/tutorial/
[2] http://marianoguerra.com.ar/efene/docs/lib/rest.html

Cheers,
  Volker

Re: Webserver in Efene

From:
Volker Mische
Date:
2011-12-17 @ 15:10
On 12/15/2011 11:02 PM, Volker Mische wrote:
> Hi,
> 
> I wanted to play with Efene as a webserver a bit. I found a tutorial
> [1], but it doesn't work. I always get an empty reply back. Did the
> syntax change?
> 
> I also didn't find anything other than the documentation about the REST
> module [2], which isn't that useful :)
> 
> [1] http://marianoguerra.com.ar/efene/tutorial/
> [2] http://marianoguerra.com.ar/efene/docs/lib/rest.html
> 
> Cheers,
>   Volker

I found the problem, I haven't had included the path to the
simple_bridge module.

Though it's still weird that it is a silent error.

Cheers,
  Volker

Re: [efene] Re: Webserver in Efene

From:
Mariano Guerra
Date:
2011-12-24 @ 17:38
On Sat, Dec 17, 2011 at 4:10 PM, Volker Mische <volker.mische@gmail.com> wrote:
> On 12/15/2011 11:02 PM, Volker Mische wrote:
>> Hi,
>>
>> I wanted to play with Efene as a webserver a bit. I found a tutorial
>> [1], but it doesn't work. I always get an empty reply back. Did the
>> syntax change?
>>
>> I also didn't find anything other than the documentation about the REST
>> module [2], which isn't that useful :)
>>
>> [1] http://marianoguerra.com.ar/efene/tutorial/
>> [2] http://marianoguerra.com.ar/efene/docs/lib/rest.html
>>
>> Cheers,
>>   Volker
>
> I found the problem, I haven't had included the path to the
> simple_bridge module.
>
> Though it's still weird that it is a silent error.

it is weird, also I think rebar should put the .beam files in the base
ebin so we don't have to add the paths ourselves.

do you think it's ok? or maybe theres another way to do it?