librelist archives

« back to archive

problem regaring creating development enviornment

problem regaring creating development enviornment

From:
Ankit Bhootra
Date:
2014-03-13 @ 10:47
Respected sir,

 

I want to implement converse js chat application in my website. And I want
to change some of the default things of converse and change chat box/window
UI, I followed all the instructions mentioned in converse js official
website, I successfully implemented till the creation of "node-modules"
folder, but when I run command "grunt fetch", on my cmd, it gives me this
response


build failed with error code 1 '.' is not recognized  as an internal or
external command,

operable program or batch file

 

Done, without errors

 

And there is no "components" folder created for the third party js
libraries, so I am not able to do any work of my chat application, can you
please help me about this problem that why components directory is not
created.

 

Many thanks and Regards

Ankit Bhootra

Re: [conversejs] problem regaring creating development enviornment

From:
Jc Brand
Date:
2014-03-14 @ 19:07
On Thu, Mar 13, 2014 at 04:17:32PM +0530, Ankit Bhootra wrote:
>    Respected sir,
> 
>     
> 
>    I want to implement converse js chat application in my website. And I want
>    to change some of the default things of converse and change chat
>    box/window UI, I followed all the instructions mentioned in converse js
>    official website, I successfully implemented till the creation of
>    “node-modules” folder, but when I run command “grunt fetch”, on my cmd, it
>    gives me this response
> 
>    build failed with error code 1 '.' is not recognized  as an internal or
>    external command,
> 
>    operable program or batch file
>

Sounds like you don't have Grunt installed. Did you run "npm install" first?

After running "npm install", try "./node_modules/.bin/bower update" and see if
you get any errors.

If you don't get any errors, run "grunt fetch" and all should be fine.

Re: [conversejs] problem regaring creating development enviornment

From:
Colton Yaroschak
Date:
2014-04-04 @ 17:59
Hello JC Brand,

I’m inquiring about the error when running the grunt fetch command. I’m 
trying to use Converse.js on my existing web application but the min files
causing confliction with other elements on my page (jquery). I was going 
through your guide to prepare the development environment to use the 
non-min non-amd version but I’m getting stuck on the same portion as some 
other people, the creation of the components folder.

I’m running Windows 7 x64, I’ve installed node.js successfully, I was able
to run npm install in the converse.js directory, the node_modules were 
downloaded, but when trying to run the grunt fetch command I’m getting hit
with the following error:

C:\Users\Colton Yaroschak\Downloads\converse.js>.\node_modules\.bin\grunt fetch
Running "fetch" task
build failed with error code 1'.' is not recognized as an internal or 
external command,
operable program or batch file.

Done, without errors.

The components folder is not being created, I tried creating it manually, 
but the command still does nothing.

When running bower update command I get the following result: (I ran npm 
–g update bower before this)

C:\Users\Colton Yaroschak\Downloads\converse.js>.\node_modules\.bin\bower update

bower cached        https://raw.github.com/strophe/strophejs-plugins/02310ad1b8d
a2962cd05b0f4bceaecca134efed4/muc/strophe.muc.js#e-tag:0611a296f
bower validate      e-tag:0611a296f against https://raw.github.com/strophe/strop
hejs-plugins/02310ad1b8da2962cd05b0f4bceaecca134efed4/muc/strophe.muc.js#*
bower cached        https://raw.github.com/jcbrand/strophejs-plugins/75c8693992b
c357c699b6d615eeb396e799f5c02/disco/strophe.disco.js#e-tag:f8b8df613
bower validate      e-tag:f8b8df613 against https://raw.github.com/jcbrand/strop
hejs-plugins/75c8693992bc357c699b6d615eeb396e799f5c02/disco/strophe.disco.js#*
bower cached        https://raw.github.com/jcbrand/strophejs-plugins/75c8693992b
c357c699b6d615eeb396e799f5c02/vcard/strophe.vcard.js#e-tag:4f623cfe0
bower validate      e-tag:4f623cfe0 against https://raw.github.com/jcbrand/strop
hejs-plugins/75c8693992bc357c699b6d615eeb396e799f5c02/vcard/strophe.vcard.js#*
bower cached        https://raw.github.com/jcbrand/strophejs-plugins/75c8693992b
c357c699b6d615eeb396e799f5c02/roster/strophe.roster.js#e-tag:dd79124e5
bower validate      e-tag:dd79124e5 against https://raw.github.com/jcbrand/strop
hejs-plugins/75c8693992bc357c699b6d615eeb396e799f5c02/roster/strophe.roster.js#*

bower ENOGIT        git is not installed or not in the PATH


So is git required for grunt fetch to work? Is it possible for you to just
send me a copy of the components folder? Do you have any suggestions to 
avoid the jquery conflict with the min files?

Thanks!

-Colton

Re: [conversejs] problem regaring creating development enviornment

From:
Rodolfo Gonzalez
Date:
2014-04-04 @ 18:18
2014-04-04 11:59 GMT-06:00 Colton Yaroschak <
colton.yaroschak@itracksolutions.com>:

>
> So is git required for grunt fetch to work? Is it possible for you to just
> send me a copy of the components folder? Do you have any suggestions to
> avoid the jquery conflict with the min files?
>

I think the answer is "not exactly", but it seems that some code is cloned
from a git. You could always install it:

http://git-scm.com/book/en/Getting-Started-Installing-Git

Re: [conversejs] problem regaring creating development enviornment

From:
Jc Brand
Date:
2014-04-05 @ 07:37
On Fri, Apr 04, 2014 at 12:18:45PM -0600, Rodolfo Gonzalez wrote:
>    2014-04-04 11:59 GMT-06:00 Colton Yaroschak
>    <[1]colton.yaroschak@itracksolutions.com>:
> 
>      So is git required for grunt fetch to work?

Seems so. I've never tried it without git :) 

>      Is it possible for you to just send me a copy of the components folder?

Don't be lazy. Install git and learn a thing or two in the process.

>      Do you have any suggestions to avoid the jquery conflict with the 
min files? 

Yes.

https://conversejs.org/docs/html/index.html#conflicts-with-other-javascript-libraries
  
>    I think the answer is "not exactly", but it seems that some code is cloned
>    from a git. You could always install it:
>    [2]http://git-scm.com/book/en/Getting-Started-Installing-Git

Yes, the correct answer is to install git.

The software is free, but if you want to effectively use and develop it, you
still need to a pay a price (i.e. make the effort to learn how to do that).

Re: [conversejs] problem regaring creating development enviornment

From:
Ankit Bhootra
Date:
2014-03-15 @ 12:12
I have run npm install first and only after that I am running this command
"grunt fetch".
I also tried the command "bower update" as you suggested.. but this is not
working too
I am stuck now. Really need the development environment, so can change 
some of the design and other aspects.

Thanks
Ankit Bhootra

-----Original Message-----
From: conversejs@librelist.com [mailto:conversejs@librelist.com] On Behalf
Of JC Brand
Sent: Saturday, March 15, 2014 12:38 AM
To: conversejs@librelist.com
Subject: Re: [conversejs] problem regaring creating development enviornment

On Thu, Mar 13, 2014 at 04:17:32PM +0530, Ankit Bhootra wrote:
>    Respected sir,
> 
>     
> 
>    I want to implement converse js chat application in my website. And I want
>    to change some of the default things of converse and change chat
>    box/window UI, I followed all the instructions mentioned in converse js
>    official website, I successfully implemented till the creation of
>    “node-modules” folder, but when I run command “grunt fetch”, on my cmd, it
>    gives me this response
> 
>    build failed with error code 1 '.' is not recognized  as an internal or
>    external command,
> 
>    operable program or batch file
>

Sounds like you don't have Grunt installed. Did you run "npm install" first?

After running "npm install", try "./node_modules/.bin/bower update" and see if
you get any errors.

If you don't get any errors, run "grunt fetch" and all should be fine.

Re: [conversejs] problem regaring creating development enviornment

From:
Jc Brand
Date:
2014-03-16 @ 07:28
On Sat, Mar 15, 2014 at 05:42:14PM +0530, Ankit Bhootra wrote:
> I have run npm install first and only after that I am running this 
command "grunt fetch".
> I also tried the command "bower update" as you suggested.. but this is 
not working too
> I am stuck now. Really need the development environment, so can change 
some of the design and other aspects.

Nobody can help you if you don't provide more details. To merely say something
is "not working" is practically useless.

If things are "not working" then you must be getting error messages when you
run "npm install" or "bower update".

What are these error messages?

> -----Original Message-----
> From: conversejs@librelist.com [mailto:conversejs@librelist.com] On 
Behalf Of JC Brand
> Sent: Saturday, March 15, 2014 12:38 AM
> To: conversejs@librelist.com
> Subject: Re: [conversejs] problem regaring creating development enviornment
> 
> On Thu, Mar 13, 2014 at 04:17:32PM +0530, Ankit Bhootra wrote:
> >    Respected sir,
> > 
> >     
> > 
> >    I want to implement converse js chat application in my website. And I want
> >    to change some of the default things of converse and change chat
> >    box/window UI, I followed all the instructions mentioned in converse js
> >    official website, I successfully implemented till the creation of
> >    “node-modules” folder, but when I run command “grunt fetch”, on my cmd, it
> >    gives me this response
> > 
> >    build failed with error code 1 '.' is not recognized  as an internal or
> >    external command,
> > 
> >    operable program or batch file
> >
> 
> Sounds like you don't have Grunt installed. Did you run "npm install" first?
> 
> After running "npm install", try "./node_modules/.bin/bower update" and see if
> you get any errors.
> 
> If you don't get any errors, run "grunt fetch" and all should be fine.
> 

Re: [conversejs] problem regaring creating development enviornment

From:
Ankit Bhootra
Date:
2014-03-21 @ 05:21
I am getting this error every time after running "grunt fetch"

  build failed with error code 1 '.' is not recognized  as an internal or
external command,

  operable program or batch file
  Done Without errors

	I have also run bower update as you suggested.
So can you please explain what should be solution for this

Thanks
Ankit Bhootra

-----Original Message-----
From: conversejs@librelist.com [mailto:conversejs@librelist.com] On Behalf
Of JC Brand
Sent: Sunday, March 16, 2014 12:59 PM
To: conversejs@librelist.com
Subject: Re: [conversejs] problem regaring creating development enviornment

On Sat, Mar 15, 2014 at 05:42:14PM +0530, Ankit Bhootra wrote:
> I have run npm install first and only after that I am running this 
command "grunt fetch".
> I also tried the command "bower update" as you suggested.. but this is 
not working too
> I am stuck now. Really need the development environment, so can change 
some of the design and other aspects.

Nobody can help you if you don't provide more details. To merely say something
is "not working" is practically useless.

If things are "not working" then you must be getting error messages when you
run "npm install" or "bower update".

What are these error messages?

> -----Original Message-----
> From: conversejs@librelist.com [mailto:conversejs@librelist.com] On 
Behalf Of JC Brand
> Sent: Saturday, March 15, 2014 12:38 AM
> To: conversejs@librelist.com
> Subject: Re: [conversejs] problem regaring creating development enviornment
> 
> On Thu, Mar 13, 2014 at 04:17:32PM +0530, Ankit Bhootra wrote:
> >    Respected sir,
> > 
> >     
> > 
> >    I want to implement converse js chat application in my website. And I want
> >    to change some of the default things of converse and change chat
> >    box/window UI, I followed all the instructions mentioned in converse js
> >    official website, I successfully implemented till the creation of
> >    “node-modules” folder, but when I run command “grunt fetch”, on my cmd, it
> >    gives me this response
> > 
> >    build failed with error code 1 '.' is not recognized  as an internal or
> >    external command,
> > 
> >    operable program or batch file
> >
> 
> Sounds like you don't have Grunt installed. Did you run "npm install" first?
> 
> After running "npm install", try "./node_modules/.bin/bower update" and see if
> you get any errors.
> 
> If you don't get any errors, run "grunt fetch" and all should be fine.
> 

Re: [conversejs] problem regaring creating development enviornment

From:
Jc Brand
Date:
2014-03-21 @ 07:39
On Fri, Mar 21, 2014 at 10:51:36AM +0530, Ankit Bhootra wrote:
> I am getting this error every time after running "grunt fetch"
> 
>   build failed with error code 1 '.' is not recognized  as an internal 
or  external command,
> 
>   operable program or batch file
>   Done Without errors
> 
> 	I have also run bower update as you suggested.
> So can you please explain what should be solution for this

No. I cannot explain the solution because you haven't given me enough
information to figure out what the problem is.

I asked you what error messages you are getting when you run "npm install" or
"bower update" and you still haven't given them to me.

JC

> -----Original Message-----
> From: conversejs@librelist.com [mailto:conversejs@librelist.com] On 
Behalf Of JC Brand
> Sent: Sunday, March 16, 2014 12:59 PM
> To: conversejs@librelist.com
> Subject: Re: [conversejs] problem regaring creating development enviornment
> 
> On Sat, Mar 15, 2014 at 05:42:14PM +0530, Ankit Bhootra wrote:
> > I have run npm install first and only after that I am running this 
command "grunt fetch".
> > I also tried the command "bower update" as you suggested.. but this is
not working too
> > I am stuck now. Really need the development environment, so can change
some of the design and other aspects.
> 
> Nobody can help you if you don't provide more details. To merely say something
> is "not working" is practically useless.
> 
> If things are "not working" then you must be getting error messages when you
> run "npm install" or "bower update".
> 
> What are these error messages?
> 
> > -----Original Message-----
> > From: conversejs@librelist.com [mailto:conversejs@librelist.com] On 
Behalf Of JC Brand
> > Sent: Saturday, March 15, 2014 12:38 AM
> > To: conversejs@librelist.com
> > Subject: Re: [conversejs] problem regaring creating development enviornment
> > 
> > On Thu, Mar 13, 2014 at 04:17:32PM +0530, Ankit Bhootra wrote:
> > >    Respected sir,
> > > 
> > >     
> > > 
> > >    I want to implement converse js chat application in my website. 
And I want
> > >    to change some of the default things of converse and change chat
> > >    box/window UI, I followed all the instructions mentioned in converse js
> > >    official website, I successfully implemented till the creation of
> > >    “node-modules” folder, but when I run command “grunt fetch”, on 
my cmd, it
> > >    gives me this response
> > > 
> > >    build failed with error code 1 '.' is not recognized  as an internal or
> > >    external command,
> > > 
> > >    operable program or batch file
> > >
> > 
> > Sounds like you don't have Grunt installed. Did you run "npm install" first?
> > 
> > After running "npm install", try "./node_modules/.bin/bower update" and see if
> > you get any errors.
> > 
> > If you don't get any errors, run "grunt fetch" and all should be fine.
> > 
> 

Re: [conversejs] problem regaring creating development enviornment

From:
Ankit Bhootra
Date:
2014-03-22 @ 10:14
Thanks a ton for your reply.
Ok.. after spent a lot of time on this.. finally I succeed with creation 
of components folder.
But there was strophe file was missing on that.. so I have downloaded that
from strophe's official website.

Now all working fine when I use require.js.

But if I am using prebinding, then there another strange problem of 
invisibility of chat box. And by looking at the console, I am getting 
these words:-
"Error: A "url" property or function must be specified"
 
Why I am getting this error only in case of prebinding.
Thanks
Ankit

-----Original Message-----
From: conversejs@librelist.com [mailto:conversejs@librelist.com] On Behalf
Of JC Brand
Sent: Friday, March 21, 2014 1:09 PM
To: conversejs@librelist.com
Subject: Re: [conversejs] problem regaring creating development enviornment

On Fri, Mar 21, 2014 at 10:51:36AM +0530, Ankit Bhootra wrote:
> I am getting this error every time after running "grunt fetch"
> 
>   build failed with error code 1 '.' is not recognized  as an internal 
> or  external command,
> 
>   operable program or batch file
>   Done Without errors
> 
> 	I have also run bower update as you suggested.
> So can you please explain what should be solution for this

No. I cannot explain the solution because you haven't given me enough 
information to figure out what the problem is.

I asked you what error messages you are getting when you run "npm install"
or "bower update" and you still haven't given them to me.

JC

> -----Original Message-----
> From: conversejs@librelist.com [mailto:conversejs@librelist.com] On 
> Behalf Of JC Brand
> Sent: Sunday, March 16, 2014 12:59 PM
> To: conversejs@librelist.com
> Subject: Re: [conversejs] problem regaring creating development 
> enviornment
> 
> On Sat, Mar 15, 2014 at 05:42:14PM +0530, Ankit Bhootra wrote:
> > I have run npm install first and only after that I am running this 
command "grunt fetch".
> > I also tried the command "bower update" as you suggested.. but this 
> > is not working too I am stuck now. Really need the development 
environment, so can change some of the design and other aspects.
> 
> Nobody can help you if you don't provide more details. To merely say 
> something is "not working" is practically useless.
> 
> If things are "not working" then you must be getting error messages 
> when you run "npm install" or "bower update".
> 
> What are these error messages?
> 
> > -----Original Message-----
> > From: conversejs@librelist.com [mailto:conversejs@librelist.com] On 
> > Behalf Of JC Brand
> > Sent: Saturday, March 15, 2014 12:38 AM
> > To: conversejs@librelist.com
> > Subject: Re: [conversejs] problem regaring creating development 
> > enviornment
> > 
> > On Thu, Mar 13, 2014 at 04:17:32PM +0530, Ankit Bhootra wrote:
> > >    Respected sir,
> > > 
> > >     
> > > 
> > >    I want to implement converse js chat application in my website. 
And I want
> > >    to change some of the default things of converse and change chat
> > >    box/window UI, I followed all the instructions mentioned in converse js
> > >    official website, I successfully implemented till the creation of
> > >    “node-modules” folder, but when I run command “grunt fetch”, on 
my cmd, it
> > >    gives me this response
> > > 
> > >    build failed with error code 1 '.' is not recognized  as an internal or
> > >    external command,
> > > 
> > >    operable program or batch file
> > >
> > 
> > Sounds like you don't have Grunt installed. Did you run "npm install" first?
> > 
> > After running "npm install", try "./node_modules/.bin/bower update" 
> > and see if you get any errors.
> > 
> > If you don't get any errors, run "grunt fetch" and all should be fine.
> > 
> 

Re: [conversejs] problem regaring creating development enviornment

From:
Jc Brand
Date:
2014-03-24 @ 08:32
On Sat, Mar 22, 2014 at 03:44:18PM +0530, Ankit Bhootra wrote:
> Thanks a ton for your reply.
> Ok.. after spent a lot of time on this.. finally I succeed with creation
of components folder.
> But there was strophe file was missing on that.. so I have downloaded 
that from strophe's official website.
> 
> Now all working fine when I use require.js.
> 
> But if I am using prebinding, then there another strange problem of 
invisibility of chat box. And by looking at the console, I am getting 
these words:-
> "Error: A "url" property or function must be specified"

That's a backbone error and happens when sync is called but it doesn't have a
URL to sync to.

In converse.js we use backbone.localStorage to sync, but this only gets set up
once converse.js has connected to an XMPP server (because we need a valid JID
before we can sync).

Sounds like your client didn't connect to the XMPP server.

What are the values you send to the initialize method?