librelist archives

« back to archive

None

None

From:
Alexandre Coloma
Date:
2014-02-22 @ 07:16
Hi, i'm trying to use converse.js in our CRM, but i have a problem,

I get 1.6x branch with prebind, i can send messages but i can´t receive it,
but the connection is on. I check the connection and i see that i receive
responses but the messages no appear on screen .

Another problem is thay if i get last release, there are some dependencies
(crypto) and crash grunt fetch. Thundermore if i actualize bown
configuration and i resolve it dosn't go with prebind.

Could you help me?
Thanks in advance
Alex Coloma

None

From:
Huxisuz Hu
Date:
2014-04-26 @ 03:59
Hello JC Brand,

I posted a quetion of "prebind authorization failed on openfire" days ago,
firstly sorry for putting that post on github.. could you  give a look at
the below problem description and give some suggestion?

my setting for converse:
require(['converse'], function (converse) {
converse.initialize({
debug: true,
auto_list_rooms: false,
auto_subscribe: false,
bosh_service_url: 'http://chat.ufutx.net:7070/http-bind'(using punjab),
prebind: true,
jid: '<?php echo $sessionInfo['jid'] ?>',
sid: '<?php echo $sessionInfo['sid'] ?>',
rid: '<?php echo $sessionInfo['rid'] ?>',
hide_muc_server: false,
i18n: locales['en'], /
show_controlbox_by_default: false,
xhr_user_search: false
});
});

and the php prebind code is using cany-chat php-prebind as you mentioned on
your website:
$xmppPrebind = new XmppPrebind('chat.ufutx.net', '
http://chat.ufutx.net:7070/http-bind/', 'myresource', false, false);
please note that 'myresource' could be different from 'resource' generated
by converse.js, may this cause issue?

and when I checked the console output, it shows the session is attached,
and did sent a get roster iq to openfire, but it then get
an error iq:
<iq type="error" from="chat.ufutx.net">
<query xmlns="http://jabber.org/protool/disco#info"/>
<error code="400" type="modify"/>
</iq>

and the user is actually not logged into openfire, punjab is working ok.
How  can I resolve this error ? your help is greatly appreciated! thanks .


Best Regards

lancelothuxi

Re: [conversejs]

From:
Jc Brand
Date:
2014-02-23 @ 09:38
On Sat, Feb 22, 2014 at 08:16:08AM +0100, Alexandre Coloma wrote:
>    Hi, i'm trying to use converse.js in our CRM, but i have a problem,
> 
>    I get 1.6x branch with prebind,

Do you mean the 0.6.x branch of converse.js, or are you referring to something
else?

>    i can send messages but i can´t receive
>    it, but the connection is on. I check the connection and i see that i
>    receive responses but the messages no appear on screen .

Please explain what you mean by "I check the connection". What specifically do
you do?

Where do you see that you receive responses?

>    Another problem is thay if i get last release, there are some dependencies
>    (crypto) and crash grunt fetch. Thundermore if i actualize bown
>    configuration and i resolve it dosn't go with prebind.

If you use the minified files in the ./build directory, you won't have any
issues with dependencies.

If you want to run the unminified files (i.e. a development environment), then
you need to follow the steps explained in the documentation to set that up:

https://conversejs.org/docs/html/index.html#development

Regards
JC

Re: [conversejs]

From:
Alexandre Coloma
Date:
2014-02-23 @ 09:50
yes, i followed the steps before sent support mail, in the latest versión
of 0.6.x branch, i can´t receive messages with prebind options, if I use
another old version (0.6.3) i can´t do it.

In other hand respect 0.7.x versions, in latest version there are some
dependencies that it's not ressolved, (crypto.js) because git references
repository doesn`t exist.

Rewards and thanks for your response
Alex




2014-02-23 10:38 GMT+01:00 JC Brand <lists@opkode.com>:

> On Sat, Feb 22, 2014 at 08:16:08AM +0100, Alexandre Coloma wrote:
> >    Hi, i'm trying to use converse.js in our CRM, but i have a problem,
> >
> >    I get 1.6x branch with prebind,
>
> Do you mean the 0.6.x branch of converse.js, or are you referring to
> something
> else?
>
> >    i can send messages but i can´t receive
> >    it, but the connection is on. I check the connection and i see that i
> >    receive responses but the messages no appear on screen .
>
> Please explain what you mean by "I check the connection". What
> specifically do
> you do?
>
> Where do you see that you receive responses?
>
> >    Another problem is thay if i get last release, there are some
> dependencies
> >    (crypto) and crash grunt fetch. Thundermore if i actualize bown
> >    configuration and i resolve it dosn't go with prebind.
>
> If you use the minified files in the ./build directory, you won't have any
> issues with dependencies.
>
> If you want to run the unminified files (i.e. a development environment),
> then
> you need to follow the steps explained in the documentation to set that up:
>
> https://conversejs.org/docs/html/index.html#development
>
> Regards
> JC
>

Re: [conversejs: No messages received with prebind option]

From:
Jc Brand
Date:
2014-02-23 @ 17:13
On Sun, Feb 23, 2014 at 10:50:04AM +0100, Alexandre Coloma wrote:
>    yes, i followed the steps before sent support mail, in the latest versión
>    of 0.6.x branch, i can´t receive messages with prebind options, if I use
>    another old version (0.6.3) i can´t do it.

You didn't answer the other two questions I asked.
  
>    In other hand respect 0.7.x versions, in latest version there are some
>    dependencies that it's not ressolved, (crypto.js) because git references
>    repository doesn`t exist.

If you set up the dev environment like explained in the docs, then all
dependencies should be resolved because Bower will fetch all of them.

I'm currently working on the master branch (0.7.x) without any issues.

Please run again the steps mentioned in the documentation and double check that
there aren't any errors.

https://conversejs.org/docs/html/index.html#development

Then, if you still have the unresolved dependency, provide more detailed
information on what the exact error message is and where you see it. For
example in the browser or in the console?

Also, as mentioned before, you can use the minified source code, which contains
converse.js and all its dependencies. It's in the ./build directory.

Have you tried using that?

Regards
JC

>    Rewards and thanks for your response
>    Alex
> 
>    2014-02-23 10:38 GMT+01:00 JC Brand <[1]lists@opkode.com>:
> 
>      On Sat, Feb 22, 2014 at 08:16:08AM +0100, Alexandre Coloma wrote:
>      >    Hi, i'm trying to use converse.js in our CRM, but i have a problem,
>      >
>      >    I get 1.6x branch with prebind,
> 
>      Do you mean the 0.6.x branch of converse.js, or are you referring to
>      something
>      else?
> 
>      >    i can send messages but i can´t receive
>      >    it, but the connection is on. I check the connection and i see that
>      i
>      >    receive responses but the messages no appear on screen .
> 
>      Please explain what you mean by "I check the connection". What
>      specifically do
>      you do?
> 
>      Where do you see that you receive responses?
> 
>      >    Another problem is thay if i get last release, there are some
>      dependencies
>      >    (crypto) and crash grunt fetch. Thundermore if i actualize bown
>      >    configuration and i resolve it dosn't go with prebind.
> 
>      If you use the minified files in the ./build directory, you won't have
>      any
>      issues with dependencies.
> 
>      If you want to run the unminified files (i.e. a development
>      environment), then
>      you need to follow the steps explained in the documentation to set that
>      up:
> 
>      [2]https://conversejs.org/docs/html/index.html#development
> 
>      Regards
>      JC
> 
> References
> 
>    Visible links
>    1. mailto:lists@opkode.com
>    2. https://conversejs.org/docs/html/index.html#development