librelist archives

« back to archive

borg list hangs during backup

borg list hangs during backup

From:
Alex Gorbachev
Date:
2015-09-11 @ 22:57
Hello, while running borg create (takes 16+ hours in our case), borg list
hangs.  Is this expected behavior and can it be changed?

Also this leads to another question about data integrity running borg
extract while borg create is also running?

This seems related to https://github.com/jborg/attic/issues/110

Thank you,
Alex

Re: borg list hangs during backup

From:
Alex Gorbachev
Date:
2015-09-11 @ 23:06
The snap/clone actually works using the method described in
https://borgbackup.github.io/borgbackup/internals.html
"in case you run into troubles with the locks, you can just delete the
lock.* directory and file IF you first make sure that no Borg process is
running on any machine that accesses this resource"

this seems to allow list/extract operations to proceed

On Fri, Sep 11, 2015 at 6:57 PM, Alex Gorbachev <ag@iss-integration.com>
wrote:

> Hello, while running borg create (takes 16+ hours in our case), borg list
> hangs.  Is this expected behavior and can it be changed?
>
> Also this leads to another question about data integrity running borg
> extract while borg create is also running?
>
> This seems related to https://github.com/jborg/attic/issues/110
>
> Thank you,
> Alex
>

Re: borg list hangs during backup

From:
Alex Gorbachev
Date:
2015-09-11 @ 22:59
...and a practical question from below limitation: if, for example, a
recovery is needed while backup is running, can one snapshot/clone the
filesystem (i.e. zfs snapshot) and somehow remove the exclusive lock?  The
original repo does not suffer, since it will not be modified.

On Fri, Sep 11, 2015 at 6:57 PM, Alex Gorbachev <ag@iss-integration.com>
wrote:

> Hello, while running borg create (takes 16+ hours in our case), borg list
> hangs.  Is this expected behavior and can it be changed?
>
> Also this leads to another question about data integrity running borg
> extract while borg create is also running?
>
> This seems related to https://github.com/jborg/attic/issues/110
>
> Thank you,
> Alex
>